Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,736
Community Members
 
Community Events
176
Community Groups

rsync-deploy - Permission denied (publickey,password).

Public key and password work fine for sftp-deploy. 

am i missing something?

 - step:
name: Staging
deployment: staging
script:
- echo "Deploying to staging environment"
- pipe: atlassian/rsync-deploy:0.4.0
variables:
USER: 'USER'
SERVER: 'SERVER'
REMOTE_PATH: '/home/deweese/irisstaging'
LOCAL_PATH: '.'

 

1 answer

0 votes

Hi @Brandon DeWeese . Your configuration looks correct. Have you tried passing your ssh key to the pipe explicitly via the SSH_KEY parameter? I also suggest enabling debug mode by setting the DEBUG variable to true.

Yea, doesn't work and the debug doesn't really provide any clues. Still can't get it to work 2 years later. What a tool.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events