repository size never changes

Dears,
I just wanted to ask why the repository size is still the same (1.8 GB) even after we removed a lot of large files which are of size 600 MB or even larger.
We have deleted all unused branches as well.
The actual code size without large files that were removed is about 24MB.
Please advice if there is any way to reduce the size of the repository.

1 answer

0 vote

Hi Dina! Sometimes it takes some time for the garbage collection to run in the remote, so that's the reason why you won't see any changes in size. I've checked your Bitbucket Cloud account but I couldn't find any repos there. If you let me know the affected username and repo name I can run a garbage collection for you.

Looking forward to your response!

Cheers,

Ana 

Hello Ana ,

Thank you for your response you can check the repo from here 

https://bitbucket.org/mobiledoctors/ios

 

and the user name is DinaHussieny

 

Regards,

Dina Hussieny

Hello Ana,

I am waiting your response hope to hear from you the soonest.

Regards,

Dina Hussieny

Hi Ana & Dina

I am facing a simular issue. My repository reached 1.9GB so I followed the instructions here:
https://confluence.atlassian.com/bitbucket/reduce-repository-size-321848262.html

I did it in two steps. First I managed to reduce it to 1.4GB. That's at least what I could see locally using the commands 

git count-objects -v 

and

du -hs .git/objects

But strangely enough, when looking at the repository size on the Bitbucket website, I see double size: 2.8GB!!!

Then in a second step I managed to reduce the size locally to 600MB. I tried to push and it failed because it says I exceeded 2GB.

What should I do here ? Wait for Bitbucket to do its garbage collection and try again, or is there something more serious here ?
The repository name is 
https://michaelstv@bitbucket.org/smartertv/stv.git

But it is a private repo.

It is kind of urgent because we are stuck now, unable to push anything. Thanks!

Michael

Hello Ana,

 

When will you be available to supporting us in solving this issue ?

Hi @Dina Husseiny, we've run a gc on the remote repo and the size is ~1.8GB, the output is:

$ git count-objects -Hv 
count: 0
size: 0 bytes
in-pack: 39645 packs: 1
size-pack: 1.76 GiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

You mentioned in your initial comment that the size of your local repo is now 24 MB, can you try now pushing that one so everything you removed locally will be reflected in the remote? The instructions can be found at Reduce repository size.

Let us know if you have any questions!

Regards,

Ana

Hi @Michael Boccara, after running a git gc on your repo, it's now showing a size of ~1.3GB , this is the output:

$ git count-objects -Hv 
count: 0
size: 0
bytes in-pack: 72637
packs: 1
size-pack: 1.33 GiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

Can you try pushing now the reduced repository? If you need any further assistance, let us know :)

Regards,

Ana

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

23,369 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you