Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access. Edited

I have seen other answers related to this but nothing has worked out for me.

I am using git command line on Linux and Mac OS, and whenever I try to push or pull changes, I get this error:

remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.

When I logout and login again to BitBucket, this issue gets resolved, for a while, and I can perform git remote operations.

Is this because somewhere(probably a CI/CD pipeline) I had provided my password in the past and it is still prompting with the same password so BitBucket blocks my account on repeated attempts? If so, is there a way to know where this request originates from?

 

1 answer

1 accepted

1 vote
Answer accepted

Hello Syed,

This issue does seem to be rather frustrating, especially when you’re needing to get work done and you have to step through the lockout process to complete your work. What I would suggest is to your review your session logs within Bitbucket cloud to see where logins are coming from.

If you wish to check your current account's active session, you can navigate to Avatar(bottom left) > Bitbucket Settings > Sessions

Source documentation: How to clear Bitbucket Cloud account's active session?

This will show where all of your logins are coming from. This should help in locating where your lockouts are coming from.

I hope this proves helpful and you’re able to find the cause of your account lockouts.

Regards,
Stephen Sifers

Hi Stephen,

Thanks for the instructions, Sessions do give an idea about where the requests are coming from and can help in narrowing the problem down using the OS version and IP address.

Like Stephen Sifers likes this

WORKAROUND: Currently the workaround I have done is to use SSH keys, which doesn't prompt me for the Bitbucket password so I dont have to logout & login to do remote operations.

The Sessions do help to investigate but it is my fault that I don't remember which servers I had provided my password on and also, I don't think I will be able to access those servers now anymore.

Like # people like this

I found this solution almost working. I was using Azure DevOps and I was getting that same error.

I created an App Password which clears the problem.

Like Юрий Котов likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,880 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you