Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


remote: Repository is over the size limit (4 GB) and will not accept further additions.

I have a problem, the size of the code repository is more than 4GB, I encountered the following error, I tried to delete some files, but it didn't work. Please help to check.
git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin 14.x_tutorial_dlc:14.x_tutorial_dlc
Pushing to
remote: Repository is over the size limit (4 GB) and will not accept further additions.

remote: Learn how to reduce your repository size:
= [up to date] excle -> excle
! [remote rejected] 14.x_tutorial_dlc -> 14.x_tutorial_dlc (pre-receive hook declined)
error: failed to push some refs to ''

2 answers

1 vote
Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 12, 2022

Hi @韦哲, thank you for reaching out to Atlassian Community. 

I confirmed you raised an internal ticket with our support team, and a support engineer has already run a GC against your repository, so I understand everything is working as expected now. In any case, to avoid any possible misunderstandings or miscommunication that may arise from discussing the same matter on two different platforms, let’s focus on the ticket instead. 

Once the ticket is resolved, feel free to share the resolution here to help other community members that may have the same issue.

Kind regards,

0 votes
Alex Koxaras _Relational_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Oct 12, 2022

Hi @韦哲 

As suggested by the error message, you have to reduce the the repository size. So this link is useful this


thank you for your help!

I did this , but it does not works.


git branch <keeper>

git reset --soft @{u}^

git push --force

git merge --ff-only <keeper>

git branch -d <keeper>



Still the same error as above


I checked some sources and should need your help to perform GC operations,

urgent, thanks


git gc

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events