Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,801
Community Members
 
Community Events
176
Community Groups

remote: Repository is over the size limit (4 GB) and will not accept further additions.

remote: Repository is over the size limit (4 GB) and will not accept further additions.
remote:
remote: Learn how to reduce your repository size: https://confluence.atlassian.com/x/xgMvEw.
To https://bitbucket.org/*/*.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://*@bitbucket.org/*/*.git'

I can not push due to reaching the sit limit of the repo.

How can I delete the big files/folders and push the commit.

 

2 answers

2 accepted

0 votes
Answer accepted
Caroline R Atlassian Team Mar 22, 2022

Hi, @asadullah797, thank you for reaching out to Atlassian Community.

Could you please tell me the last 3 letters of the name of this workspace and repository, so I can identify it? We can either run a GC to remove dangling commits to try to reduce its size, or we can temporarily increase the repo size to allow you to push the changes without these large files once you remove them locally.

Please let me know if you have additional questions regarding this case.

Kind regards,
Caroline

Hi Caroline;

Here is the complete path for the repo;

<removed due to privacy reasons>

Best regards,

Asad

Caroline R Atlassian Team Mar 24, 2022

Hi, @asadullah797, thanks for the additional information! 

I ran a GC against this repo, but the size didn't change, so I have temporarily increased the repository size to allow you to push your code without these large files. After you push it, please let me know so I can run a GC again to remove these files from the remote repository. 

Please let me know if you have any questions.

Kind regards, 
Caroline 

Caroline R Atlassian Team Mar 30, 2022

Hi, @asadullah797, I would like to check if you were able to remove the large files/folders and pushed these changes back to your remote repo. I'm asking this because we have tried to run a GC several times and the size hasn't changed, so we understand the large files are still there. 

Please let me know if you need any help in this process. 

Kind regards, 
Caroline 

Hi Caroline,

Can you please check the repo size.

I have removed the redundant data and push to server but changes didn't reflect on the server.

Can you please confirm?

Best regards,

Asad

Caroline R Atlassian Team Apr 04, 2022

Hi @asadullah797, I run the GC against your repo again, but the size remains the same. Could you please run the following command locally and share the output with us? 

git count-objects -vH

And the push you mentioned, was it successful? 

Kind regards, 
Caroline  

Hi Caroline,

The log the above command:

git count-objects -vH
count: 4
size: 16.00 KiB
in-pack: 13042
packs: 1
size-pack: 4.39 GiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes


The push is successful but I could not see changes on the server repo.

Thanks
Caroline R Atlassian Team Apr 04, 2022

Hi, @asadullah797, thanks for sharing the output with us. 

The size of the local repository corresponds to the remote repository, both are showing 4 GB. In this case, I suggest that you analyze the files that are part of this repo and check if you have binary or large files that could be increasing the repo size. If you do, I recommend that you move such files to LFS. 

The following documentation has a very good explanation of how to move files to LFS:

In case you need help with this, I see this repo is under a paid workspace, so you should be able to create an internal ticket with us, so we can access this repo and help you with this analysis.  

You can open a support ticket via https://support.atlassian.com/contact, in "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as the product. Make sure you inform the paid workspace when creating this ticket. 

Please feel free to share any additional questions regarding this case.

Kind regards, 
Caroline 

0 votes
Answer accepted
Mikael Sandberg Community Leader Mar 22, 2022

If you look at the link in the error message it will take you to a KB describing how to reduce the size of your repository. If it was the last push that took you over the limit, you will have to reverse that push by rewinding the history by creating a new temp branch, reset the original branch to a commit before the last one, force push the new head, and then restore your changes. Once you enabled Git LFS you can push those changes. 

If you need to run garbage collection you can contact support to remove dangling/bad commits. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events