"Write access is required for uploading LFS objects" when pushing to repo? Edited

Hi,

My colleague & I have been happily using SourceTree (OSX 2.6.3) to push/pull to our repo (with LFS) hosted on bitbucket for the past month or so, however yesterday my colleague suddenly started getting the following error when trying to push:

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree -c lfs.customtransfer.bitbucket-media-api.path=/Applications/SourceTree.app/Contents/Resources/git_local/git-lfs/git-lfs-bitbucket-media-api push -v --tags origin refs/heads/master:refs/heads/master
Pushing to https:<repo>
batch response: Write access is required for uploading LFS objects
error: failed to push some refs to 'https:<repo>'
Git LFS: (0 of 9 files) 0 B / 26.51 MB
Completed with errors, see above

 

Pulling works fine, just not pushing.  Nothing obvious has changed, & the LFS is reporting it still has over 2GB of space available.  I've spent most of today googling for answers but so far have had no luck.  Any ideas?

 

3 answers

0 votes
Dave Call I'm New Here Sep 21, 2017

I just got the same error, yesterday as well.  I had stashed some local changes, pulled from the repo, and then applied my stash and committed.  When I try to push the commit, I see the same error.  Haven't been able to figure out what's going on yet.  Hoping someone has an idea on this.  Thanks for the post.

0 votes
Dave Call I'm New Here Sep 21, 2017

So, haven't been able to find a solution with SourceTree.  But, I downloaded GitKraken, opened the repo, and was able to push successfully with that.  Just thought I'd let anyone know that was having the same issue.

https://www.gitkraken.com/

This one is also not working. Still getting the same error.

This error have also begun popping up on different machines in our office. We haven't identified the cause of this issue, but we figured out a temporary work around by switching from HTTPS to SSH. We don't appreciate this, but it is a temporary workaround until we figure out what is causing it.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

631 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot