Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,938
Community Members
 
Community Events
176
Community Groups

"VS30063: You are not authorized to access https://api.bitbucket.org."

Hello!

I am trying to run my CI/CD pipelines on Azure DevOps, however when I click run I am getting the following error on the Azure DevoOps end:

Unauthorized request. Bitbucket returned the error: 'VS30063: You are not authorized to access https://api.bitbucket.org.'

I have tried adding a service connection from Azure DevOps. I have authorized Azure through OAuth. I tried using an App Password, but I wasn't sure where to login with the app password. I am not sure how to fix this. Has anyone encountered something like this?

Thank you!

1 answer

0 votes
Patrik S Atlassian Team Apr 07, 2022

Hello @Judy M ,

Welcome to Atlassian Community!

Are you receiving the error 'VS30063: You are not authorized to access https://api.bitbucket.org.' during your pipeline build, or before it even starts ?

To connect your Azure instance to Bitbucket Cloud you have the following options :

  • OAuth : you will be redirected to Bitbucket website and will have to grant Azure access. The Bitbucket account you are logged in while creating the connection should be an administrator of the workspace.
  • Basic Authentication (username and app password) : Create a service connection in Azure using your bitbucket username (not email address) and an App Password (not your account password) with the required permissions. You can try creating an App Password with full permissions and check how it goes.

Microsoft has a detailed documentation on how to configure the connection to Bitbucket Cloud, which covers both scenarios above, and you can find it in the following link :

Hope that helps! Let us know in case you run into any issues trying the suggestions above.

Thank you, @Judy M .

Kind regards,

Patrik S

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events