Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,707
Community Members
 
Community Events
168
Community Groups

"Exit code: 1" when running "yarn install" for BitBucket repo

I had a public github repo in the `dependencies` section of my `package.json`, and it worked fine. It looked like this:

> git+ssh://git@github.com/TheUser/TheRepo.git#TheCommitHash

I tried adding another one (a private BitBucket repo that I've created):

> git+ssh://git@bitbucket.org/stremio/stremio-qml-kit.git#be6d087ad9a481519a4766da893c3be74a6b8819

and when I ran `yarn install`, I got:

yarn install v1.2.0
[1/4] Resolving packages...
error Command failed.
Exit code: 1
Command: git
Arguments: archive --remote=ssh://git@bitbucket.org/stremio/stremio-qml-kit.git refs/heads/master package.json
Directory: /home/stefan/Desktop/jobsrc/wifi-setup
Output:

info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Any ideas?

**Note:** I tried running this manually:

> git archive --remote=ssh://git@bitbucket.org/stremio/stremio-qml-kit.git refs/heads/master package.json

and got:

fatal: sent error to the client: git upload-archive: archiver died with error
remote: fatal: pathspec 'package.json' did not match any files
remote: git upload-archive: archiver died with error

4 answers

Having the same issue exactly, any fixes?

Old issue, but for anyone coming across this 3+ years later:

Ensure you have a package.json in your private repository. A minimal setup generated from npm init / yarn init will suffice.

{
"name": "private-package-name",
"version": "0.1",
"description": "short description",
"repository": "git@bitbucket.org:user/repo.git",
"author": "you",
"license": "MIT",
"private": true
}

Did anyone manage to fix this issue?

+1 Same issue with bitbucket private repositories. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events