pipeline memory limit - elasticsearch exceeded memory limit.

 

Hello,

I am trying to run my functionnal tests in our bitbucket pipeline with elasticsearch an mysql as services.

But everytime, the pipeline launches, I get this error : elasticsearch exceeded memory limit.

Here is the content of my bitbucket-pipelines.yml : 

 

image:  php:7.1.1
options:
  size: 2x
pipelines:
  default:
    - step:
        caches:
          - composer
        script:
          - apt-get update && apt-get install -y unzip
          - curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer
          - composer install
          - bin/bootstrap
          - ./vendor/bin/simple-phpunit
        services:
          - elasticsearch
          - database
definitions:
  services:
    elasticsearch:
      image: elasticsearch:alpine
    database:
      image: mysql
      environment:
        MYSQL_ROOT_PASSWORD: root

 

I would be very gratefull of some help or some pointers.

Thx in advance,

Vincent.

 

 

1 answer

0 vote
Motoki Wu I'm New Here Jan 24, 2018

I'm having memory issues as well. A pipeline that worked last Friday hits the memory limit. I even added the `2x` option but it still hits the memory limit.

The build should be pretty similar to each other but all of a sudden a 2x memory is not enough?

For me, it feels like the pipeline can not even build the elasticsearch docker image !!

I'm having a similar issue with an instance of the "microsoft/mssql-server-linux" SQL Server service.

It looks like the additional memory options don't apply to services, they're only shared with the pipelines, so when I start my pipeline, the mouseover on the log tabs in pipelines shows:

  • Build 7GB
  • mssql - 1GB

I can't see any obvious way to re-balance this for my needs.

Hi,

You guys found a way to solve this or will I have to install my own CI tool ?

I got around it for now using a jvm.options file for elastic to limit the memory. I created a new dockerfile that was based on the elastic image we need, added in a jvm.options file with:

-Xms512m
-Xmx512m

This keeps it under the 1GB service size.

They've recently added service size limitations that presumably you could just bump your elastic container to 1.5 or so (https://confluence.atlassian.com/bitbucket/use-services-and-databases-in-bitbucket-pipelines-874786688.html#UseservicesanddatabasesinBitbucketPipelines-Definingaservicewithcustomresourcelimits) but I can't get it to work.

If I follow their example with a "memory: 1536m" the online validator tool says it's expecting an integer, but if I put an integer it ignores it. Perhaps it's so new that their documentation is ahead of their implementation so maybe you'll have luck in the next days/weeks.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,764 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you