Getting the error "No such file or directory exist " on using the
- pipe: microsoft/azure-aks-deploy:1.0.2
@Reethu How did you create your pipeline yml? Have you checked this doc?
Hi @Reethu ,
Thank you for your question!
It would be nice if you could share with us more details about your case: logs, pipelines configuration, etc.
Cheers,Oleksandr Kyrdan
Thanks Oleksandr for prompt response.while configuring the bitbucket pipeline to deploy my image from azure container registry to azure kubernetes, i am using two steps:
- Build -(ran successfully) - step: &Deployimage:name: atlassian/default-image:2name: Deploy Imagetrigger: manualscript: - pipe:microsoft/azure-aks-deploy:1.0.2variables:AZURE_APP_ID: *****AZURE_PASSWORD: ****AZURE_TENANT_ID: ******AZURE_AKS_NAME: ******AZURE_RESOURCE_GROUP: ******KUBECTL_COMMAND: 'apply'KUBECTL_ARGUMENTS: '-f ******.yaml'DEBUG: 'true' # Optionalwhile triggering the deploy from pipeline , am getting error like below on executing script in deploy step.+ pipe:microsoft/azure-aks-deploy:1.0.2<br>bash: pipe:microsoft/azure-aks-deploy:1.0.2: No such file or directory.<br><br>
microsoft
+ pipe:microsoft/azure-aks-deploy:1.0.2<br>
bash: pipe:microsoft/azure-aks-deploy:1.0.2: No such file or directory.<br><br>
Am getting same error on trying with pipes pipe:atlassian/azure-aks-deploy:1.0.2pipe:microsoft/azure-aks-deploy:1.0.2
I rechecked on this doc , and copied the pipe 'script: - pipe: atlassian/azure-aks-deploy:1.0.2 .
Thanks !
Thanks for the response
@Reethu are you still having the issue?
Unfortunately, I should announce that microsoft does not support this pipe anymore. Instead atlassian supports this instead. Please, use readme from here for more examples https://bitbucket.org/atlassian/azure-aks-deploy/src/master/ .
If you're still having the issue, could you please share more logs? I've just executed both variants (BIT with space, pipe: atlassian/azure-aks-deploy:1.0.2) and it worked.
Please, report to us, if you have questions or issues with this pipe. For now I cannot reproduce your case.
Regards, Galyna
Hello @Halyna Berezovska @Reethu
I am also facing same issue with
following is the error i am getting:
<span>ERROR: The received access token is not valid: at least one of the claims 'puid' or 'altsecid' or 'oid' should be present. If you are accessing as application please make sure service principal is properly created in the tenant.</span><span>✖ Error logging in using azure service principal!</span><span>+ echo 'ERROR: The received access token is not valid: at least one of the claims '\''puid'\'' or '\''altsecid'\'' or '\''oid'\'' should be present. If you are accessing as application please make sure service principal is properly created in the tenant.'</span><span>+ [[ 1 != \0 ]]</span><span>+ fail 'Error logging in using azure service principal!'</span><span>+ echo -e '\e[31m✖ Error logging in using azure service principal!\e[0m'</span><span>+ exit 1</span>
<span>ERROR: The received access token is not valid: at least one of the claims 'puid' or 'altsecid' or 'oid' should be present. If you are accessing as application please make sure service principal is properly created in the tenant.</span>
<span>✖ Error logging in using azure service principal!</span>
<span>+ echo 'ERROR: The received access token is not valid: at least one of the claims '\''puid'\'' or '\''altsecid'\'' or '\''oid'\'' should be present. If you are accessing as application please make sure service principal is properly created in the tenant.'</span>
<span>+ [[ 1 != \0 ]]</span>
<span>+ fail 'Error logging in using azure service principal!'</span>
<span>+ echo -e '\e[31m✖ Error logging in using azure service principal!\e[0m'</span>
<span>+ exit 1</span>
<span>Please help me with this issue. i already wasted 2 days to look into this issue but not getting solution.</span>
@Reethu if you already solve this issue your help would be appriciate.
<span>Regards</span>
<span>Sanket</span>
@Sanket Sultan the application says to you that your token does not have enough permissions scope
<span> The received access token is not valid: at least one of the claims '\''puid'\'' or '\''altsecid'\'' or '\''oid'\'' should be present.</span>
Recheck your credentials including azure app password, you're passing.
Also, we recommend to switch to
- pipe: atlassian/azure-aks-deploy:1.0.2
I have to remind that microsoft has stoppped maintaining the pipe.
@Halyna Berezovska @Yevhen @Oleksandr Kyrdan I solved this issue .
the solution for this issue is that you have to give the service principal as a contributor role and we have to attach that service principal to the AKS cluster that we using for the deployment
Thanks,
Sanket
Hi @Sanket Sultan
Thanks for contributing and sharing the solution with the community!
Best regards,Oleksandr Kyrdan
It looks like you're new here. Sign in or register to get started.