Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

/opt/atlassian/pipelines/agent/build does not exist

I'm using for pipelines with 'image: maven:3.3.3' and everything worked fine untill this morning, during

git clone ... to $BUILD_DIR ...

Cloning into '/opt/atlassian/pipelines/agent/build'... 

the forlder /opt/atlassian/pipelines/agent/build does not exist and System error. What has changed with pipelines?

 

 

12 answers

The opt/atlassian/pipelines/agent/build/** issues have to do with how your bitbucket-pipelines.yml file is configured to handle your artifacts.

Your artifacts files that have to do with your bitbucket run and the files inside of the build/** only exist inside of the run and then are deleted/removed when the run is over. If you want to get to them you have to set it up correctly in your .yml file to get to them. Learn more about artifacts and how to configure them here: https://confluence.atlassian.com/bitbucket/using-artifacts-in-steps-935389074.html

Seems like these bastards are persistently ignoring the problem.

BitBucket team, we really need some update on this. We've experiemented with our configuration, lots of LS commands to debug, everything looks correct.

 

This is affecting PRODUCTION environment.

In my case this error occurred because i had a symlink in the project. .gtignore didnt seem to work in my case ... this was on windows.
I removed the offending folder/symlink in my case because refactoring is easy. 

I'm also not able to deploy my app to an App Engine due to ERROR: (gcloud.app.deploy) [/opt/atlassian/pipelines/agent/build/app.yaml] does not exist.

High I'm having this problem now

1s+ gcloud --verbosity=error app deploy app.yamlERROR: (gcloud.app.deploy) [/opt/atlassian/pipelines/agent/build/app.yaml] does not exist.

I've the same problem now.

Seems to be fixed now.

Screen Shot 2018-01-14 at 01.51.45.png
Where and how? Am having the same problem right now and I don't know how to fix it.

Like krasnikov87 likes this

Same error 

/opt/atlassian/pipelines/agent/build/venv/.Python does not exist

Did you get a fix for this please? Am having the same problem.

Like srugano likes this

Same error. No change in the pipeline configuration since the last successful run.

I had the same issue but it resolved itself after about an hour. I guess theres been some kind of patch.

I have the same Problem but with

image: kanti/buildy:5.6 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,850 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you