Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

new runner doesnt want to start

Nieznaj, Piotr April 4, 2023

Hello y'all,

 

Iam running a bitbucket runner in a kubernetes cluster.

It has been working fine until I needed to re-apply the job today.

When starting it up, I get this error:

A�=�
[bb-runner-j4b5t][runner] + ./entrypoint.sh
[bb-runner-j4b5t][runner] Error: Unable to access jarfile �d?�y
A corrupt file has been uploaded ? 
This is the image iam getting: 

docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-runner

 

Appreciate all and any help, cause now it refuses to start and our builds are standing still.

1 answer

0 votes
Riley Venable
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 4, 2023

Based on the error message you received, it seems like the jarfile has been corrupted. You may want to try removing and re-deploying the Kubernetes object spec for the Bitbucket Pipelines Docker-based Linux Runner in your cluster. Here are the steps you can follow:

1. Use `kubectl delete` command to delete the current deployment of the runner in your cluster.

2. Confirm that the runner has been deleted by running `kubectl get` command.

3. Reapply the job by running the Kubernetes object spec file that you used before.

4. Check the logs to confirm that the runner has started successfully. If the issue persists, you may want to consider using a different image for the runner or contacting Atlassian support for further assistance.

Nieznaj, Piotr April 6, 2023

Yeah, tried that without any luck.

I ended up setting up a whole new runner in bitbucket and configuring my job according to that. It worked. 

Thanks for your reply!

Siva Abbannagari December 24, 2023

Did you figured this out i get exactly same error?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events