Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

mysql 8.0 fails on pipelines

I have problem with pipelines and mysql 8

I have mysql service in my pipelines:

definitions:
services:
mysql:
image: mysql:8.0.4 #loselesslive/mysql8, jasonmu/mysql-native-password
command: ['--character-set-server=utf8mb4', '--collation-server=utf8mb4_unicode_ci','--default-authentication-plugin=mysql_native_password', 'sed -i '/^\[mysqld\]$/a\default-authentication-plugin=mysql_native_password' /etc/my.cnf']
restart: always
ports:
- "3306:3306"
environment:
TZ: Europe/Vilnius
MYSQL_DEFAULT_AUTH: 'mysql_native_password'
MYSQL_DATABASE: 'homestead'
MYSQL_ROOT_PASSWORD: 'secret'
MYSQL_USER: 'homestead'
MYSQL_PASSWORD: 'secret'

when i run pipeline i got error "Connect Error: SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client" like in

https://stackoverflow.com/questions/52364415/the-server-requested-authentication-method-unknown-to-the-client-php
https://github.com/laradock/laradock/issues/1390
https://github.com/laradock/laradock/issues/1392

 

if i could run script to run sql and command line i can fix it but  how?

 

1 answer

i rewrite mysql docker with mine  and it works like default

https://hub.docker.com/r/bondas83/mysql-native-password

Hi,

I tried to use your docker image in my bitbucket pipeline configuration.

It looks like the setup it's working, mysql server is up. But as soon as application tries to connect, I get the following error:

  An exception occurred in driver: SQLSTATE[HY000] [2002] No such file or directory                                                                       

 

Any idea?

Can confirm @Julius Šmatavičiuscustome mysql 8 container is working for me. Thanks!

Be good if Atlassian had a native fix for this.

yes, it works

i use such config

definitions:
services:
mysql:
image: bondas83/mysql-native-password
environment:
MYSQL_DATABASE: 'testing'
MYSQL_ROOT_PASSWORD: 'secret'
MYSQL_USER: 'homestead'
MYSQL_PASSWORD: 'secret'

Thank you Julius, after hours of searching many forums, yours is the only one working for me.

This should be fixed so that we don't have to use a custom container. I'm very surprised more people aren't complaining about this. Is no one using MySQL v8?

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

485 views 5 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you