Hi Team,
While running a self-hosted runner I am getting the below error, even though I have memory space in my system and disabled swap.
before it was working fine, but suddenly stopped working since from 3 days,
Status: Downloaded newer image for docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-runner:1
+ ./entrypoint.sh
[0.005s][warning][os,thread] Failed to start thread "GC Thread#0" - pthread_create failed (EPERM) for attributes: stacksize: 1024k, guardsize: 4k, detached.
#
# There is insufficient memory for the Java Runtime Environment to continue.
# Cannot create worker GC thread. Out-of-system resources.
# An error report file with more information is saved as:
# /opt/atlassian/pipelines/runner/hs_err_pid10.log
system resources:
1) ubuntu 20.04 LTS
2) 8gb RAM machine
Please help on this !!