issues cloning a repository

Hello,

I have a fresh (latest version) of stash installed on windows server and i was successfully able to commit and push a new repository (about 38 mb).  

Then i tried to clone that repository from a different directory on my workstation, but getting errors.

roman@MATRIX ~/Documents/Work/mfbtestpull
$ git clone http://rbaranov@stash.*****.com/scm/mfb/reponame-web
.git
Cloning into 'reponame-web'...
Password for 'http://rbaranov@stash.*****.com':
remote: Counting objects: 634, done.
remote: Compressing objects: 100% (449/449), done.
efrror: RPC failed; result=56, HTTP code = 2002.86 MiB/s
fatal: early EOF
atal: The remote end hung up unexpectedly
fatal: index-pack failed

roman@MATRIX ~/Documents/Work/mfbtestpull
$

So i tried cloning the repository from the server itself where stash is and that worked fine.  Over the network there seems to be an issue.  I've tried to clone smaller repository over the network that we have, like wordpress theme that i committed, and was able to clone that successfully.  Also running latest git on server and client. 1.9.5 i believe.

 

One thing i noticed is that on initial commit of the problem repository, there were some end of line warnings, but that should really matter right?

Also some things to note, im doing a clone over http, meaning i don't have https or ssh installed or setup for that server.   Would that matter?

And a final thing,  i downloaded a archive plugin which adds a download button to repository.  Clicking that button on the problem repository it looks like it starts the download but then a network error occurs.  

This is a bran new machine, so its hard to believe that its a network issue.  (having my internal guys take a loot at that meanwhile)

Any recommendations or ideas to try?

 

Thank you

 

2 answers

Ok, did some more work, turns out to be an issue with http protocol.  We enabled ssh (don't forget to open the port) and i was able to clone through ssh.

The next item was to get https working.  We added a certificate to server and you can access server through https, but cloning through https produces a new error...

$ git clone https://rbaranov@stash.*************.org/scm/mfb/reponame-we
b.git
Cloning into 'reponame-web'...
fatal: unable to access 'https://rbaranov@stash.******.org/scm/mfb/reponame-web.git/': SSL certificate problem: unable to get local issuer certificate

0 vote

Hi Roman,

From your last answer, it sounds like you're using a self-signed certificate.

You will need to add this self-signed certificate to the certificate store used by Git. I believe that this article should help you:

Let us know how you go.

Best regards,
Thiago Bomfim

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,756 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you