Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

how to use app passwords?



received emails about "Bitbucket Cloud is ending support for Atlassian account password usage for interacting with Bitbucket API and Git over HTTPS".

There is no further information, how to retrieve an app password and how to use that later on.

I managed to get an app password after some searching (thanks for that, some words would have been helpful).

But i am still failing to push to the remote repository (remote: invalid credentials). Google was helpful and i found a stackoverflow entry, which mentioned that url template:

git remote set-url origin https://[app-label]:[app-password][your-repo].git

But that also did not work. What is wrong pls?


Greetings and thank you for any help


If that problem will not be solved, we have to leave bitbucket.


4 answers

0 votes

Hi @uwobaer,

The app password should be used in combination with your Bitbucket username, and not with the app password label.

If you
1. Open your repository on Bitbucket Cloud website
2. Select the Source page from the left-hand menu
3. On that page, select the Clone button from the top right corner
4. In the new panel that shows up, select HTTPS from the top right corner. You will then see in that panel the git clone command with an HTTPS URL, including your Bitbucket username

If you want to change the remote url of your clone with the git remote set-url command, you can use either the URL

Or, if you want to include the app password in the URL


BitbucketUsername replace with the username of your Bitbucket account which can also be found here
app-password replace with the value of the app password you created
workspace-id replace with the workspace ID of the workspace where this repo belongs to
repo replace with the repo slug

The values for BitbucketUsername, workspace-id, and repo can also be seen in the URL in the Clone dialog if you follow the 4 steps I mentioned at the beginning of my reply.

If you are using a credential manager:

You can check if your machine is using a credential manager for Git with the following commands:

git config --system credential.helper
git config --global credential.helper

The first command will show if a credential helper for Git has been set for all users in the system, and the second command will show if a credential helper for Git has been set for your user.
If a credential manager is used, make sure you remove from it any saved credentials for

If you use a Git GUI client for pulling/pushing instead of a terminal application, check if there are any saved credentials for in that client and if your Bitbucket account has been added there with username+password.

If you are still facing issues, please let us know the following so we can better help you:

1. What is the URL format you are using now
2. The full output of the git command that is failing (please mask in the output the actual username, workspace, and repo values)
3. The output of the following commands on your machine

git config --system credential.helper
git config --global credential.helper

4. If you are using a Git GUI client, and if so which one

Please feel free to let me know if you have any questions.

Kind regards,

Found an answer myself, the problem was in the permissions for the app password. Please you must give more info about that!

i had to create a new app password, that has read/write on projects and repositories. Not sure if that is really correct or is intended by bitbucket. no clue. there was absolutely no help info on that dialog and you also can not see later, which concrete permissions the app password actually has :(

so my problem is solved, but i am absolutely not sure if that really is the end of the story

when i instead use the url template


 i get the error: The requested URL returned error: 403

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events