git-svn clone fails with "RA layer request failed: REPORT of '/svn/repository/!svn/me':"

We want to move to BitBucket, but we're not succeeding at cloning our repo

The full error message:
"RA layer request failed: REPORT of '/svn/repository/!svn/me': Could not read response body: Secure connection truncated (https:myserverurl) at /Applications/Xcode.app/Contents/Developer/usr/share/git-core/perl/Git/SVN/Ra.pm line 290."

Already tried "git svn fetch"
We've already tried to use the fetch command to resume the process, but it's happening VERY frequently. A dev from my team adapted a script he found online, which requested 10 commits at a time, to request 2 commits at at a time - we are still running into this problem

We need another solution
We have an SVN repository of 100k+ commits, and this is not a workable situation.  Any suggestions would be greatly appreciated.

2 answers

Seems like there are 4 or 5 relevant results here.

It's almost certain the issue is on SVN's side, not Bitbucket's.

Thanks for responding, Seth.  As I generally don't like wasting people's time, we had already looked at web searches and the suggested actions.

All the responses we've seen are basically 'persevere' - with 105k revs in the repository, persevering is not an option with which we are comfortable, since such a bumpy process does not fill us with a sense of confidence about the integrity of the resulting Git repository.

This is not a BitBucket issue, it appears to be a git svn issue. It does not appear to be a network issue (pipe size, https) or anything else we can identify.  Our SVN server is simply responding to git svn requests, the work of writing the clone repository is presumably being done by the local machine.

Thanks for directing me to the google search that brought me to this page, Seth. You're extremely helpful.

If you are just trying to migrate svn to Git, try [SubGit](https://subgit.com/), free [download](https://subgit.com/download), and [documentation](https://subgit.com/documentation/). SubGit is a Java implementation, that is useful for both 1-time migrations and for mirroring svn to Git repositories and _v.v._ SubGit worked for me when `git-svn` didn't. SubGit works on _any_ platform with the Java JRE. (FYI: If you have the Java JDK, and have set `JAVA_HOME` make sure the path is correct.). After downloading SubGit, extract the zip file, and enter the bin folder. Then follow the online documentation. A batch file for Windows and a shell file for Mac and Linux are both in the extracted `bin` folder. For Windows just replace `subgit` with `subgit.bat` in the following example:

$ subgit import --svn-url path://to/your/svn/repo GIT_REPO_PATH

This will create a new Git repo at `GIT_REPO_PATH` from the subversion repo given by the URL. See the documentation for other options such as specifying how you want to map `trunk/branches/tags/shelves` etc.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

2,304 views 9 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you