Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

git push origin not working

When I try the command $ git push origin I get the message "Everything up-to-date" but when I check my repository in Bitbucket I see the new verion of the code is not uploaded and there are no cahnges.

Please help me out. I am new to this.

10 answers

1 accepted

8 votes
Answer accepted

Have you committed your changes before pushing?

Yes I used the below commands:

$ git commit -m "Jul 8 update"
$ git add .
$ git push origin master
I got the message Everything up-to-date
Like # people like this

Do git add first and then commit.

Like # people like this

Thanks Jobin. I got your point and it worked to some extent. However, on doing the commit I recevied the following messages and it is still not getting pushed to the repository.

gunjan@Niyamgiri:~/tribalrights$ git push origin masterTo ssh://

! [rejected] master -> master (non-fast-forward)

error: failed to push some refs to 'ssh://'

To prevent you from losing history, non-fast-forward updates were rejected

Merge the remote changes (e.g. 'git pull') before pushing again. See the

'Note about fast-forwards' section of 'git push --help' for details.

---I also tried the below command --

gunjan@Niyamgiri:~/tribalrights$ git push -u origin --allTo ssh://

! [rejected] master -> master (non-fast-forward)

error: failed to push some refs to 'ssh://'

To prevent you from losing history, non-fast-forward updates were rejected

Merge the remote changes (e.g. 'git pull') before pushing again. See the

'Note about fast-forwards' section of 'git push --help' for details.

Like Nilesh Chatre likes this

Looks like somebody pushed changes to the repository after you pulled from it. Try pulling again, merge changes, resolve conflicts, commit and push again.

same problem with me.... fuck 

trying from 2 days but still not working...

i have to upload my files to my new repositary..

but i can't upload it..

the error is still there in git bash.

I had the exact same problem. Nothing helped untill I tried this:

git pull --rebase origin master

After that, run push command i.e.

git push -u origin master


Like # people like this

it worked for me..thanks alot

thanks worked for me too

it work for me thanks alot

Thanks... It worked for me... You saved my day!!!

git push origin master --force

I had the same problem .Hope it will work  .

You saved my day. I don't know what exactly the problem is either with bitbucket or android studio? I have been working hard to resolve this issue but finally your git command helped me.  

I solved problem with command:

 git pull --allow-unrelated-histories

Thank you, I had this error

! [rejected] master -> master (fetch first)
error: failed to push some refs to ''
hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

and it solved by this command. And write "git push -u origin master" after this command worked.

You're welcome, I find somewhere else, but not found right solution. So I posted here for all you guy need it.


What worked for me:

   - Open the repository on bitbucket

   - Go to "Repository settings"

   - In "Repository details" > "Large File Storage (LFS)" tick "Allow LFS"

   - Than I was able to push w/o the error saying "failed to push some refs"


I am facing this problem and i am traying to solve by avobe comment..but i can't solve this then i wrote "git push --all" and i got it🥰🥰.if you face same problem .i suggest to you ..try this ..In Sha Allah you will get it..

Screenshot (318).png

Guy's if you are facing same issue push forcefully git push origin master --force 

git pull --rebase origin master

git push -u origin master

Try this..It will work. Worked for me:)

Make sure that you add  files

git status 

git add .

git commit 

git push 


I had the same problem I solve it by this way. Hope it will work 

git commit -m "initial commit"
git push origin master

For some reason when I did this it worked...  

Wow, thanks a lot !!

Bitbucket is getting uglier everyday. The most lethal combination is Spring STS and Bitbucket. 

Bitbucket will fail you whenever you need it the most without any good reason.

It getting sluggish like Microsoft Windows Everyday.

<p>bitbucket is not good anymore</p>
Like Karl Nicholas likes this

i face a lot of problems in bitbucket. fuck

Like Issac Nguyen likes this

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events