git gc on remote repo please

Jean-Paul September 27, 2022

I've seen a fair share of people requesting a "git gc" on their remote repos, since this seems not possible via the userinterface I'm here also asking if someone from Atlassian could please give this a litle swirl.

I have three repos in a shared workspace that cause my ocd to kick in:

blu********am/s*******vr.ar*********al.b***en.stl.git (currently showing as 288 MB)
blu********am/s*******vr.ar*********al.g**t.kgv.git (currently showing as 62 MB)
blu********am/s*******vr.ar*********al.g**t.stl.git (currently showing as 120.5 MB)

Hope this works, much appreciated!

1 answer

1 accepted

0 votes
Answer accepted
Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 27, 2022

Hi, @Jean-Paul, thank you for reaching out to Atlassian Community.

I ran the GC against your repositories and managed to reduce their size. 

I also would like to share with you that we have a feature request to allow users to mark repositories for git GC, as you can check here:

Please consider adding yourself as a watcher to receive the updates as we make progress with this. If you are not familiar with our Feature Request Policy, you can read more about it here.

Feel free to share any additional questions or concerns regarding this case.

Kind regards,
Caroline

Jean-Paul September 27, 2022

Thanks, that worked! Watching the issue now.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events