Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

git clone with https password for google SSO

I am using HTTPS to clone my repo on bitbucket and it asks for password. I use Google SSO to login bitbucket and google password does not work for https git clone. I created an app password and this app password does not work either.

Any idea where I can the password for https git clone? Thanks.

4 answers

For https clone

  • Create an App password, save this somewhere as you cant read it back again
  • On clone, use your username , not your email and the App password as your password when the popup happens

I had exactly this problem this morning. SSO to Bitbucket from Google. This apparently means my account does not have a password.

Cloning out my company's repo to a shared machine, I don't have my ssh keys handy, so used the `https://` URL to clone. Of course, there's a password prompt, and _nothing_ worked.

There is no way to just set a password via one's account settings, because you have to put in the non-existant password to change the password that doesn't exist. Catch-22!

I ended up working around this by logging out, then logging in with with my email address instead of SSO. Since there's no password this will never work BUT I was finally able to access a "reset my password" mechanism, and that worked to get a password set. Great! But it's not clear to me if this "logged in with different mechanisms" will cause problems down the road or not. I hope not.

Now that I have an account password, I can get past the password prompt in the the clone operation, only to find out it wants me to use an app password instead. But that's a story for another day.

Thanks Martyn. This is a shared host and I cannot put my private ssh cert on it. Thanks.

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Feb 17, 2019

Hi Lian,

can you try using ssh instead?


git clone

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events