git clone randomly fails on private repo

During composer install, the recovery of our repositories randomly fail

[RuntimeException] 
Failed to execute git clone --no-checkout 'git@bitbucket.org:xxx/xxx.git' '/var/www/symfony/vendor/xxx/xxx' && cd '/var/www/symfony/vendor/xxx/xxx' && git remote add composer 'git@bitbucket.org:xxx/xxx.git' && git fetch composer
Cloning into '/var/www/symfony/vendor/xxx/xxx'...
Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

Why ? Is there a cloning limit ?

1 answer

SSH intermittent failures

Investigating - Some users may be experiencing intermittent issues cloning or pushing repositories over SSH. We are currently investigating the issue. 
Sep 13, 16:56 UTC

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 14, 2019 in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

272 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you