git clone error: fatal: RPC failed; curl 52 Empty reply from server The remote end hung up unexpectedly

I am suddenly getting this error even when trying a fresh clone.  It happened suddenly with no changes on our end. Any advice?

 

It seems I am able to push to the remote repo.. but can't fetch, clone, pull... 

2 answers

Hello!

I've seen similar errors in the past when there's been horribly degraded network performance, or the repo is offline.  The fact that you can push to the repo probably negates that, though.

Have you tried cloning with SSH instead?

SSH with Bitbucket Cloud

Hello and thanks for the response.

This has been going on for the last few days and not only affects me in United States but also my coder in Poland and my team in the Philippines.

I haven't tried the SSH route yet... but may just to investigate further.

We actually just use BB as a way to keep our software up to date for our team when they run our applications.  We have an updater app that keeps their local copy identical to what is in the repo.  This has worked great for a long time... and suddenly this.  Any change to the fundamental process and we will have to manually update a couple hundred people smile so hoping for another option lol

In order to see if it was our updater app, I tried to just do a fresh clone on a new system and still received the same error.  This was from yet another location in the US.  

We're learning git as we go along here... so not really even sure where to start looking.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,747 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you