Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

fatal: unable to access 'https://bitbucket.org/': gnutls_handshake() failed: Handshake failed

I am using ubuntu 14.04 plz help
fatal: unable to access 'https://bitbucket.org/': gnutls_handshake() failed: Handshake failed

6 answers

1 accepted

4 votes
Answer accepted

me too.

I am using ubuntu 14.04
fatal: unable to access 'https://bitbucket.org/': gnutls_handshake() failed: Handshake failed

I was able to get it working by installing new versions of libcurl and openssl, and then compiling git from source. Trying to figure out a easier/smoother path now

how did you do this plz mentioned the steps

sudo bash

mkdir upgrade

cd upgrade

wget https://www.openssl.org/source/openssl-1.1.1g.tar.gz

tar xpvfz openssl-1.1.1g.tar.gz

cd openssl-1.1.1g

./configure 

make ; make install

cd ..

wget https://curl.haxx.se/download/curl-7.72.0.tar.gz

tar xpvfz curl-7.72.0.tar.gz

cd curl.7.72.0

./configure --with-ssl=/usr/local/ssl

make ; make install

cd ..

git clone https://github.com/git/git 

cd git

vi Makefile, change prefix= line to /usr instead of home

make ; make install

Like # people like this

(Note github, at least for now, is not disabling ciphers. ;))

Like # people like this

Worked for me on Ubuntu 14.04.

Thanks a lot @Jonathan Pullen 

0 votes
Daniel Eads Atlassian Team Aug 28, 2020

Hi all, 

I'm sorry you've had some trouble with service interruption on your Ubuntu 14.04 servers. This was a scheduled change to remove some less secure cyphers from Bitbucket Cloud - announced in February on this blog post. 

I would suggest that Ubuntu 14.04 is past its end-of-life, so I do have concerns about recommending PPAs to get the correct versions of openssl or git that have the correct cypher support. 14.04 is no longer receiving security updates from Canonical, so the most correct action to take is upgrading to a version that's still in support and working through the packages that you need at a lower version from there. I know this might not be the answer you want to hear, but I strongly suggest trying to upgrade from a security perspective.

Cheers,
Daniel | Atlassian Support

Hi , we did the upgrade to 16.06 and still occur...

curl updated as well

 

any recommendations?

This response is why I increasingly hate and avoid the cloud. You should generally not use the cloud to build anything you want to work in 10 years unless you can constantly maintain it.

 

I am increasingly hoping the idea of the cloud dies.. because

 

A: There is no cloud, it's just somebody else's computer

B: Every cloud service run by a company has a bunch of people who need to justify their salaries who will be wanting to change it

C: Those people will also often make decisions that break whatever you're doing. For example, the less secure ciphers are not really that big a security problem for a lot of us - you have to be in a position where a attacker can observe your traffic and wants to crack your authentication - and a simple warning could have been issued for undesirable ciphers, but instead your company decided to make everyone who you consider to be running too old a version of the operating system simply cease working. This behavior is common. Then, instead of offering advice on how to fix it, you assume that we're running servers in situations that *can* be upgraded.

D: Another thing that people don't understand is that because of the effects of #B - every bit of software out there is being constantly adjusted by various people - at some point software peaks, that is, it's the best it can be for a certain application - but people continue to change it. Some "upgrades" are actually downgrades - either because they offer the user less control over the application, they use more resources to achieve the same goal, or sometimes they're just plain broken. Not wanting to upgrade a operating system is a valid choice.

Like # people like this

On the list of annoying bugs, that I can't delete a reply is definitely up there. Maybe might be a more effective use of your company's time to fix things like that, rather than turning off ciphers.

Like John Smith likes this

AMEN to the above.  I can't understand the constant need to break working applications with needless changes.  I have very specific reasons to not change an O/S just because its 6 years old!

Like gazj354 likes this

I have the same problem, still trying to find a solution. So far what I know is it's becuase there is no cipher in common between git and bitbucket. Upgrading to 16.04 fixes it, but I have machines that must stay on 14.04. Another option is to use SSH instead of HTTPS but I am trying to figure out a way to get the machines that are using HTTPS to continue working.

 

 One thing that once would have worked but does not seem to now is upgrading git from the ppa - sadly, the ppa only goes to git version 2.28 and in order to be able to specify ciphers in config (as discussed in https://stackoverflow.com/questions/13114268/passing-ciphers-to-libcurl-through-git) one must have git 2.5. Apparently once upon a time the ppa had git 2.5, I can't figure out why it doesn't now.

apt-get update && apt-get install curl 
this isn't worked for me

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,845 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you