Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

fatal: The remote end hung up unexpectedly

When doing (even a real small) push I always get sad moans at the end. What to do?

git push --progress -v
Pushing to git@bitbucket.org:<user>/<project>.git

Host 'bitbucket.org' key accepted unconditionally.
(fingerprint md5 97:8c:1b:f2:6f:14:6b:5c:3b:ec:aa:46:46:74:7c:40)
Counting objects: 5, done.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 372 bytes | 0 bytes/s, done.
Total 3 (delta 1), reused 0 (delta 0)
fatal: The remote end hung up unexpectedly
fatal: The remote end hung up unexpectedly

/Peter

3 answers

I got this error regularly when we did our CVS to Git conversion and first time pushed the converted local Git repos to Bitbucket. However, unlike the how-to on the Bitbucket repo page, we used "git push -u origin --mirror" which IMO pushes branches and tags as a whole rather than in separate commands.

Although we often received the "hung up" error, we never had an evidence that data was missing, so we ignored it while still having had a mixed feeling. Even 6 months later we don't miss any data.

Today I did another first-time push for a new repo and this issue came up again. Following the description on the Bitbucket repo page it succeeded with the big "git push -u origin --all" command (1.6 GB), but fails with the small "git push -u origin --tags" command (46 MB). No tags in Bitbucket repo visible afterwards.

Again if I use "git push -u origin --mirror", the error came up too, but the data (including tags) in Bitbucket seems to be complete. Again mixed feeling.

I wonder if on Bitbucket side the transfer can succeed partially. IMO Bitbucket should detect an incomplete transfer (as indicated by the Git error) and flags the repo as erronous.

Best regards

Michael

P.S. Yes, I tried the usual "git config" tweeks to fix the error found in the forum, but to no avail. I still haven't tried the SSH way

We worked around this problem by copying a ZIP of the local repo to the Bitbucket server and then pushing the repo locally.

I get this with out pushing any information at all:

erric@akira:~/pup-modules$ git remote set-url origin ssh://git@server.tld:7999/pup/modules.git
erric@akira:~/pup-modules$ git push origin master
fatal: remote error: Not authenticated
Please authenticate and try your request again.
fatal: The remote end hung up unexpectedly

This is a brand new install of stash on RHEL 6.5

It's not origin problem nor postbuffer problem. I tried both, but still no success. Note that the actual push upload works. Probably I should not bother about the moans at the end, but still...

Regards

/Peter

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,741 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you