Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,376
Community Members
 
Community Events
175
Community Groups

curl command downloading false zip file from bitbucket after 1 March update from Atlassian.

Edited

Hi guys, 

We have been using (Linux) CURL command to download ZIP file from bitbucket "downloads" section and its working completely fine. But its not working now. We haven't changed anything except account password.

we are using URL structure as below: 

sudo curl -O -L https://bitbucket.org/<ORGANISATION>/<REPO>/downloads/Artifacts.zip -u 'username:AppPassword'

But we are getting this issue: (Actually when we hit above command this file gets downloaded)

Capture.PNG

By using -v parameter in above command, we are getting details as below:

Capture2.PNG

Also, we have tried creating new app password and added that in above command in user authentication. but its not working.

NOTE: we are aware about new authentication changes made by Atlassian, that we must use app password for authentication and we are using app password for it (not account password) but somehow those changes are not working for us.

Can anyone please tell us what we are doing wrong? because it was working before

1 answer

1 accepted

1 vote
Answer accepted
Ben Atlassian Team Mar 16, 2022

G'day Vivek!

With the change from basic GIT username/password over to AppPassword, you will now need to make use of our /2.0/repositories API endpoint with your AppPassword.
Performing API commands on direct links to files within a repository will cause an authentication issue as the deprecated authentication method is used by default.

For example, the below command will work for your purposes:

curl -X GET -O -L \

  --url https://api.bitbucket.org/2.0/repositories/<ORGANISATION>/<REPO>/downloads/Artifacts.zip \

  --header 'Authorization: Basic AppPasswordHere'

 

Hope this helps.

Cheers!

- Ben (Bitbucket Cloud Support)

Thank you so much....It Worked!!

Ben Atlassian Team Mar 16, 2022

Hey Vivek,

Not a problem, I'm glad to know that has helped you out!

Cheers

- Ben (Bitbucket Cloud Support)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events