Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,232
Community Members
 
Community Events
176
Community Groups

clone bitbucket repository to Ubuntu 18.04 using command line failed

Hi

I tried to use the command  below to clone a repository to an Ubuntu 18.04 machine

git clone https://changwenx@bitbucket.org/keelerglobal/ion-build.git

It failed as below:

remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for 'https://changwenx@bitbucket.org/keelerglobal/ion-build.git/'

How can I sort out this issue?

Thanks

 

1 answer

0 votes
Mark C Atlassian Team Jul 10, 2022

Hi @changwenx,

Thank you for reaching out to the community.

Would it be possible for you to confirm if you're already using an App password when you tried cloning?

If not yet, could you try generating an App password and use it as your password credential when you clone?
If you're already using an App password, could you try clearing your Git credentials related to Bitbucket Cloud and try to clone again?

Hope it helps and let me know how it goes.

Regards,
Mark C

Hi Mark C,

I am using APP password in other computers. It works fine. 

The case is that I need to clone a bitbucket repository  to a headless Ubuntu 18.04 where no git app installed.

What I have done at this moment after failed to clone, I downloaded the repository from my computer and transferred to the headless device. It works but I thought it is better to clone the repository. 

It seems clone a bitbucket repository from command line (without app) is NOT working anymore?

Kind regards,

 

 

Changwen

Mark C Atlassian Team Jul 11, 2022

Hi @changwenx

I do believe the Git application is required for you to clone a repository in any OS environment.

Btw, would it be possible for you to confirm if you're referring to the App password generated from your Bitbucket Cloud account?

Regards,
Mark C

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events