can not login with eclipse

chuck666 May 1, 2022

ubuntu 21.10

eclipse 4.21

egit 5.13 (eclipse plugin)

since the latest bitbucket update, i no longer can connect with eclipse. (<username>@bitbucket.org/<username>/<repos>.git

it was stored in the secure store, but clearing the store did not help, keeps asking username and password.

created also a new ssh key, added pub to bitbucket, added key to eclipse.

still cannot do anything regarding the repos.

any ideas?

1 answer

1 accepted

0 votes
Answer accepted
chuck666 May 2, 2022

solved. eventually found out, that https is no longer supported. for ssh i forgot to change the git connection property in eclipse to change to ssh. after that it worked.

Rajesh_Pillai May 31, 2023

Hi Chuck, so you just changed the push config protocol from https to ssh and it worked? It would be great if you could elaborate more. I am facing the same. Did you create any ssh keys and set them before doing this. Kindly advise.

chuck666 June 1, 2023

it's quite some time back since i had this issue.

as far as i remember:

  1. setup SSH on bitbucket. there are instructions on Bitbucket how to setup SSH. download the private key
  2. change eclipse, set up ssh. see screenshots
chuck666 June 1, 2023

Screenshot from 2023-06-02 07-51-36.pngScreenshot from 2023-06-02 07-56-19.png

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events