Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

build and run docker image within the pipeline

I would like to upload my generated war in a container to be able to test an endpoint of it. So far I can build and rotate the image, but I can't access the resource in any way, it is as follows:

...
services:
- docker
script:
- ls -lia
- chmod 755 Dockerfile
- docker -v
- docker build -t imageteste .
- docker run -d -p 8040:8080 --name ordermanagement -i imageteste
- docker ps
- docker inspect ordermanagement
- docker exec -i ordermanagement sh -c "wget 172.17.0.1:8040/ordermanagement/order/all"

I've tried curl to no avail, so I'm using wget. The return is as follows:

docker exec -i ordermanagement sh -c "wget 172.17.0.1:8040/ordermanagement/order/all"
Connecting to 172.17.0.1:8040 (172.17.0.1:8040)
wget: error getting response: Connection reset by peer

The funny thing is that I ran exactly the same commands from my machine's prompt and it returns me the expected that for this resource using GET it would be 405.

1 answer

1 accepted

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

111 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you