bitbucket pipeline fails while phpunit tests pass Edited

Hello,

I would like to know why a pipeline would fail even though phpunit passes tests.

Please take a look at the screenshot attached.


Thanks,

Kind Regards,

Dmitry.

bitbucket_pipeline_fail.jpg

 bitbucket_pipeline_fail2.jpg

 

1 answer

0 votes

Hey Dmitry, pipeline uses the return code of your scripts to determine if it was successful; 0 is good, anything else is an error.

 

If you run just your phpunit tests, do they return a 0 exit code?

Hi Sebastian,

Thanks for your reply.

You are correct, it was a deployment script that was running

on a remote machine that was failing and causing a pipeline to fail.

The issue is now resolved and my pipelines complete correctly.

 

Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Thursday in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

....sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables ROLLBAR_ACCESS_TOKEN...

166 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you