Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups Cant create PR because commits not seen

I have an account on I worked locally and I promoted/pushed my changes in a dev branch. When I go on to create a pull request and I select the dev and master  for branches, I'm told that 


There are no changes

No commits on dev that aren't on master.


And I cannot create the PR using the web interface provided by If I browse the source of the two branches, I do see they're different. If I go and search for commits, I can see the commit there too. The only kind of strange thing I see is that the dev branch is not listed in the branches unless I select "All branches", that is, it is not displayed when the (default) active branches filter is selected.


Any ideas what's going on?


2 answers

After a year, the same happened to me. In half an hour the problem went away without any actions from my side. Seems like temporary problem on BitBucket server side.

Are they doing some upgrade on August 2-4? :)


As a workaround, I just created a new branch (wip) off the dev branch, I added a small change in it and then I was able to create the PR from wip into master and it contained both the commit from dev and the new one from wip. Oh, well, very strange. 

I'm seeing the same behavior, but this workaround also worked for me.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events