Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,948
Community Members
 
Community Events
177
Community Groups

bad numeric config value 'null' for 'commit.gpgsign': invalid unit

I have Eror from this commit ? have any idea solution?kw.PNG

 

4 answers

If you are on Linux, just delete the '~/.gitconfig' or '/home/$USER/.gitconfig' file. This will take git to an unconfigured state. The problem was that somehow the configuration file got changed by some unwanted operation and the value of `gpgsign` was set to `null`. Deleting the file or deleting the line containing `gpgsign` should solve the problem.

Edit: That problem is due to you have "git gpg signing" turned on, but no GnuPG installed. It's easy to disable it permanently by modyfing your .gitconfig, just type this command:

git config --global commit.gpgsign false 

Ok I managed to fix the issue following this post https://stackoverflow.com/questions/39494631/gpg-failed-to-sign-the-data-fatal-failed-to-write-commit-object-git-2-10-0 and Shayan Amani answer. Basically we need to update our gpgsign and sync the email with it inside GitHub. 

some eror, any idea please?

0 votes

Could you try the next command?


git -c commit.gpgsign=false commit

https://bbs.archlinux.org/viewtopic.php?id=264619

Hi, it looks like a common issue on GitHub, I'm trying to run a commit but I get same error then I tried your command with no succeed, any other suggestion?

OS: Solus GNU/Linux

GIT version 2.30.2

Thanks

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events