Other Atlassian products don't have a problem. Where can this be configured?
/admin/uploadplugin.action
org.springframework.web.multipart.MaxUploadSizeExceededException
exceeds the configured maximum (1048576)
Hi Bob,
Sorry for the delay. I'm afraid I couldn't reproduce it locally - it's certainly not intentional.
Just curiuos, can you upload it via the UI instead? What version of Stash are you running? Do you have any extra settings in your stash-config.properties or JVM arguments? Could you mind posting the full stacktrace?
Hopefully we can get to the bottom of this soon.
Charles
Hmmm, both 2.2.0 and 2.3.0. Yes, works fine via upload file or url, just not plugin install. I can open an issue if you want (where would be best?). So, I take it there is no configuration setting that can be adjusted as the error message suggests.
You _might_ want try setting 'avatar.max.size' in stash-config.properties to something larger than '1048576'. I don't think that's it, but that's the only value that might conceivably affect what you're seeing.
I forgot to ask, what version of amps do you have installed?
You can raise support tickets at:
https://support.atlassian.com/
Cheers,
Funny, I didn't get this notification. I ended up creating AMPS-962 since it is a development problem. AMPS 3.11.
As a workaround, could you please use a more recent version of the SDK (I'm using 4.1.5 at the moment)? The upload URL used to upload the plugins changed and isn't affected by the upload-size limitation in more recent versions.
Stefan
I am careful about switching SDK levels in general. A made a separate 4.1.7 install, but, that fails as well. No error in the logs this time, just the command line error: Install Plugin: Couldn't get the token from upm. Headers. Falling back to legacy upload.
It looks like you're new here. Sign in or register to get started.