Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

app password fail

I created an app password in bitbucket, and then called the app password. I used http basic authentication to call the rest api of bitbucket, and it kept returning unauthenticated.

3 answers

1 accepted

0 votes
Answer accepted

I have solved it, just remove the request body, a strange error message

I can use the same account to correctly access the api I just posted after logging in to bitbucket in the browser

0 votes

Hi @Miao Miao Li ,

When you create an app password, you select specific permissions for it. One possibility is that the app password does not have enough permissions for the endpoint you are using. E.g. if you're trying to read pull requests via API and the app password does not have permissions to read pull requests, then the request will fail.

Since it is not possible to view the permissions of an existing app password, I would suggest creating a new one, double check that it has appropriate permissions for the API endpoint(s) you want to use, and then make a new call with the new app password and see if it works.

If you're still having issues, please let me know:

1.  the exact API call you are making
(please feel free to replace the actual workspace-id and the repo name in the URL when you paste it here, with something like <workspace-id> and <repo-name>)

2. what is the exact response you are receiving when you make the call

so I can better help you.

Kind regards,
Theodora

When I generated the app password, I checked all the permissions. When I call the api, it still returns 401. The api I called is this https://api.bitbucket.org/2.0/repositories/ncs-nxp?page=1

I tried to replace ncs-nxp with workspace-id, but it still doesn’t work

header.put("Content-Type","application/json");
String auth="email:apppassword";
header.put("Authorization","Basic "+base64(auth));

This is the code I used for authorization

@Theodora Boudale  hello,Can you help me? I tried replacing the email address with user_name in Bitbucket profile settings, and the result will become 403 (http status)

Hi @Miao Miao Li ,

For API calls the Bitbucket username should be used, instead of the email. The email is only used for logging in to Bitbucket website. For operations like cloning/pulling/pushing via HTTPS and also for API calls, the username should be used instead.

You mentioned that you solved this by removing the request body, I'm glad you managed to figure this out.

I am not sure though what request body you were using? An API call to retrieve a workspace's repos doesn't require you to send additional data with a request body.

Kind regards,
Theodora

Just some test data, forgot to remove it. Well, the username must be the username in the account settings, not the login email address

There is an inaccurate record of the last access time on the app password, it is often not updated. If that is accurate, maybe I can find some problems earlier.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,762 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you