Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,570
Community Members
 
Community Events
176
Community Groups

Why is the fork option not showing up?

I created a bitbucket account using google authentication, and I'm trying to fork a repo, but the fork option doesn't appear. I confirmed with the repo owner, forks are not restricted and there already are more than 10 forks. I tried some other random repos and I can only clone or download, not fork. I tried using chrome and firefox on different machines (mac, pc, android)...
Any ideas?
Screen Shot 2023-01-12 at 5.13.40 PM.png

3 answers

1 accepted

0 votes
Answer accepted

I noticed that explicitly granting people read access allows them to not just read, but also fork.

I still consider it a bug, that you cannot fork a public repository, but at least there is a workaround.

The bug has been fixed now with BCLOUD-22395

0 votes

Hi @Alessandro Wilner and @Stefan Prelle,

Our development team is looking into this, I'll post here when I have an update.

Kind regards,
Theodora

@Theodora BoudaleThanks for looking into it.

I also opened a Jira ticket with Bitbucket support ( https://support.atlassian.com/requests/BBS-196964 ). The response there was

"I checked further on your request and currently, we do not have this feature available, and the workaround is the same as you have pointed out, i.e. giving user the permission to the repository after which the Fork option is available to the user."

I cannot really believe this explanation. E.g. my repo ( https://bitbucket.org/rpgframework-cloud/shadowrun6-eden/src/master/ ) had 14 forks without that I ever needed to give read permissions.

However, as a result of my bug report, a feature request for being able to fork public repos has been opened: BCLOUD-22390 - Public repository not having Fork option :)

Cheers,
  Stefan

Very odd bug, I have a large (300+ forks) public repo and this has also stopped working for me.

Testing it with a different account also has the same results as others where they dont have the option to fork anymore

Like Stefan Prelle likes this

There is a open bug ticket now - we are expected to Vote and Watch

Hi Stefan,

Apologies for the confusion created in the support ticket. This is definitely a bug, I've discussed it with my colleague who is handling your support request and informed her.

The bug was introduced after a recent update and our development team is working on it. When this is fixed, an update will be posted in the public bug report you linked.

Kind regards,
Theodora

Like Stefan Prelle likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events