Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Why does the Bitbucket trigger pipe fail?


I am following the instructions for the Bitbucket trigger pipe and get this error.

X Account, repository or branch doesn't exist.

  - pipe: atlassian/trigger-pipeline:5.0.1



       ACCOUNT: 'workspaceName'                         


for USERNAME:  looked it up in personal settings and tried as Repository variable and without it (just in quotes)

for APP_PASS:  Created a App Pass and added the value into a repository variable which i then used as $myAppPass with and without quotes

for REPOSITORY:  tried severel repos but does not help

for ACCOUNT: tried with the Account and without it and i tried workspace name and workspace id 


When i add DEBUG: 'true' i get this additional info:


DEBUG: Starting new HTTPS connection (1):
DEBUG: "GET /bitbucketpipelines/official-pipes/raw/master/ HTTP/1.1" 200 None
DEBUG: Starting new HTTPS connection (1):
DEBUG: "POST /2.0/repositories/<workspaceID>/<repository>/pipelines/ HTTP/1.1" 404 61

I want to note that i have the structure <Workspace>/<Project>/<Repository>


I have tried creating several app passwords, several usersnames and several repositories.

I have tried several permission settings and the permissions that are suggested.

The information from the error doesn't give me enough information to see what i am making wrong.



1 answer

1 accepted

0 votes
Answer accepted
Mark C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 14, 2022

Hi @Dominik Bregovic

Welcome to the community.

You mentioned that you have the structure below:


Would you be able to confirm where did you use that structure?
Also, for the REPOSITORY variable, would you be able to confirm if you only used your repository name?

For example, if your repository URL is:

Your variables should be:

  • BITBUCKET_USERNAME: my_bb_username
  • BITBUCKET_APP_PASSWORD: my_app_password
  • REPOSITORY: repo_name
  • ACCOUNT: workspace_id

Mark C

Hallo Mark,

Thank you for your response.

The URL you posted helped me to resolve my issue:


My repository is written with a uppercase  letter at the beginning. <Myrepo>

Because of your example i was able to see that it is all lowercase in the URL. <myrepo>


I changed that and everything worked fine.

Like Mark C likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events