Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Why can I not have 2 repositories with the same name even if they are in different projects?

Say I have the following project / repo hierarchy:



|----- my-first-repo


|----- my-first-repo


When I try to create the my-first-repo in the python project I get an error saying I already have a repo with the name my-first-repo.


Seems like I should be able to create repos with the same name if they are in different projects.

2 answers

1 accepted

0 votes
Answer accepted
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Oct 02, 2022

Welcome to the Atlassian Community!

It's because the repo name is part of the path.  Think of what goes on the disk - how would ./mygitwork/bob get distinguished from ./mygitwork/bob ?

Makes sense, but then why not have the project name also be part of the path.

Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 04, 2022

Hi, @Giancarlo Franchi,


We already have the following feature requests to include the project ID to the repository URL, which would allow you to create two repositories with the same name in different projects: 

I would suggest that you add your vote there (by selecting the Vote for this issue link) as the number of votes helps the development team and product managers better understand the demand for new features. 

You are more than welcome to leave any feedback, and you can also add yourself as a watcher (by selecting the Start watching this issue link) if you'd like to get notified via email on updates.

Implementation of new features is done as per our policy here and any updates will be posted in the feature request. 

Kind regards,

Thank you Caroline!

0 votes
Erez Maadani
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Oct 03, 2022

Do the projects have different keys? 

BTW, I just tried to create a repo with same name on different project and it worked great - on bitbucket cloud 



I have a the following projects:


Java --> Key = JAVA

Python --> Key = PYT


In java I have a repo called minesweeper.


I'm re-writing it in Python. So i go to create new repo. I select my workspace. Then project Python and try to create repo minesweeper.


It gives me the error that a repo with that name exists (I don't have a minesweeper repo in the python project).

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events