Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,683
Community Members
 
Community Events
176
Community Groups

Why are my credentials invalid if SourceTree says "Authentication OK"?

I just changed my password on id.atlassian.com and I also created and app password for git (for use on my remote servers). That part works fine. Now I'm trying to get SourceTree to work again on my local computer. My account was originally set up to use OAuth. I click "refresh OAuth token" and it says "Authentication OK" with a little green checkbox. But when I try to pull any of my repos, it says my credentials are invalid. I've also tried to switching to Basic authentication and using the app password I just created for git access, and I get the same "Authentication OK" status in the settings, but when I try to pull I get the same "invalid credentials" error. Can anyone help me out with this?

1 answer

1 accepted

0 votes
Answer accepted

Answered my own question in case anyone else runs into this when abandoning the old login system on the last possible day like me. I had my remote paths set to [username]@bitbucket... when I was using the old-style account password authentication. I had to remove my username from the URL and then everything worked fine with my OAuth authentication, using my BitBucket account as the Remote Account in the repo settings.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events