Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,784
Community Members
 
Community Events
165
Community Groups

Why Bitbucket cloud is showing a different size than my local repo?

Hello, in Bitbucket shows a size of 928.6 MB  but my repo locally is showing 462252 KB when I run "git count-objects -v". Am I missing something here? Is Bitbucket Cloud counting something else? I haven't change anything locally and did a git pull.

Thank you.

50 answers

1 accepted

2 votes
Answer accepted
Ana Retamal Atlassian Team Feb 02, 2018

Hi @Fricco

We have tools that allow us to see information from the user's account. We can also get temporary access to the user's account for troubleshooting purposes when the user request help, so if needed, I'll be able to access it even if the repo itself is private.

We've run a git gc from our side and the size of the repo is now 305MB. Is there anything else we can help you with?

Best regards!

Ana

Wow, thanks a lot @Ana Retamal, just to make sure, if I see a different size between what I see locally in my repo and the remote I should create this kind of post or what is the process for it?

Thank you.

Ana Retamal Atlassian Team Feb 02, 2018

You're welcome, Francisco :) The size of the repo will not be a problem until you reach the hard limit (2GB) in which case you won't be able to push any new changes. Bitbucket runs automatic garbage collections so the difference in size should be addressed soon.

However, if you're concerned about this or would like to make sure things are ok, you can always let us know here in Community and we'll run the garbage collection for you.

In case your repo does actually reach the 2GB, you can follow the instructions at Reduce repository size to fix it.

Hope that helps!

Ana

Like chibuike007 likes this

@Ana Retamal

I am facing the similar issue in my private repo https://bitbucket.org/kabuku/rinkak-mms-connect. The settings page says its size is 1.5 GB while `size-pack` of `git count-objects -v` is 450,238 KB. It's been more than a week since I noticed the gap between the sizes.

In my case, there had once been a big file in commit history, so I forked the repo to https://bitbucket.org/kenji_imamura/rinkak-mms-connect and rewrote history using BFG following the instructions to see if it helps reducing the size of the repo. Now, the settings page of the forked repo says its size is 1.6 GB while `size-pack` of `git count-objects -v` is 92,904 KB.

Will `git gc` also help my case?

Ana Retamal Atlassian Team Jul 04, 2018

Hi @Kenji Imamura! I've run a git gc on your repo kenji_imamura/rinkak-mms-connect and the size decreased to 91.0 MB. Do you need help with anything else?

Have a nice day :)

Ana

@Ana Retamal Thanks! Would you please run `git gc` on https://bitbucket.org/kabuku/rinkak-mms-connect as well ?

Ana Retamal Atlassian Team Jul 04, 2018

Hi @Kenji Imamura,I've run git gc for kabuku/rinkak-mms-connect and the size decreased to 362.3 MB. 

Cheers!
Ana

Great! Thank you so much!!

Ana Retamal Atlassian Team Jul 04, 2018

Glad I could help you! Have a great day, Kenji :)

Ana, can we run the git -gc on our remote repos stored in bitbucket ourselves or does someone on the atlassian team have to do it?

I need a cleanup on a repo. thanks.

Ana Retamal Atlassian Team Jan 24, 2019

Hi @pperez_24, I found 3 repos in your account that were reaching or exceeding the 2GB limit, and I've run a git gc on them. For one of them, the size was reduced from 2GB to 1.4GB, but for the other 2 repos the size didn't change, which means you'll have to reduce their size locally. The steps are explained in the article Reduce repository size.

Once you do that, wait a little bit for the automatic garbage collection to run on the remote. If it doesn't let us know so we can run it manually. 

Hope that helps :) 

Ana

Hi, can you please run the gc again on impressions3 ? thanks!

-p

Ana Retamal Atlassian Team Feb 13, 2019

Hi! I've run the git gc and the size decreased to 1.5 GB.

As a side note, I'd recommend you to change your username to something different from your email address, for security reasons. 

Hope that helps!

Ana

@Ana Retamal 

Hello,

we are also experiencing a similar issue with repo: https://bitbucket.org/sonnenwalzer/unity_remember

The local size-pack is about 1.2GB repo shows size of 1.8GB in settings tab since few weeks ago.

Ana Retamal Atlassian Team Mar 08, 2019

Hi @Andrea Iannella , welcome to the Community!

I've run a git gc on the remote and the size has decreased to 1.3 GB. Is there anything else we can help you with?

Best regards,

Ana

We do not have any further issues. Thank you for the quick support.

Ana Retamal Atlassian Team Mar 11, 2019

Glad I could help! 

Have a good day :) 

Ana

@Ana Retamal 

Hi,

Could you run gc on our repo? Local size-pack is 10MB while the remote shows 1.3GB.

Thanks.

Ana Retamal Atlassian Team Mar 11, 2019

Hi @Eddy Bakker , I've run a git gc on the remote and the size has decreased to 5.9 MB. 

Have a good day :D 

Ana

@Ana Retamal : could you also run gc on this repo: https://bitbucket.org/...

I did a cleanup using the BFG tool and reduced the size from 1.3gb to 400mb, but in bitbucket it shows as 1.5g.

Thanks.

Ana Retamal Atlassian Team Mar 14, 2019

Hi @Eddy Bakker , ran git gc and the size decreased to 283.5 MB. 

Cheers!

Ana

@Ana Retamal 
Hi Ana, I am also running through the same thing.
Did a cleanup with BFG and my repo got reduced from 1.3gb  to around 50mb. 
Same thing as everyone here, it still shows 1.3gb on my bitbucket account.

https://bitbucket.org/MRC-BI/hubx

I would appreciate the help

Ana Retamal Atlassian Team Apr 09, 2019

Hi Jacob, I ran a git gc on your remote and it decreased to 46.2 MB. 

Hope that helps!

Ana

@Ana Retamal  
thank you, I really appreciate it

Ana Retamal Atlassian Team Apr 10, 2019

:D

Ana Retamal Atlassian Team Oct 04, 2019

Hi @willtudorevans,

I've checked your repository 'saramek' and I could see it's just 125.7 MB. Is that the size your local repository is showing? Does it differ? Usually we won't manually run git gc unless the repositories are too big, please let us know if you need any further assistance with this!

Best regards,

Ana 

Yes thanks Ana - all fixed now! It was 2GB for a few days and then overnight dropped to 120MB.

Ana Retamal Atlassian Team Oct 04, 2019

Thanks for the update! 

Have a nice weekend,

Ana 

Hi Ana,

I'm trying to reduce the size in once of my repo's using git filter-branch and git gc.
But I'm not able to push to remote.

Could please run git gc on my repo 'ar.fx_mvp'

Ana Retamal Atlassian Team Oct 09, 2019

Hi @Gokul Rajasekhar

I've run a git gc on your remote but the size didn't change, it stays at 1.9GB. Can you confirm you've followed all the steps listed at Reduce repository size?

Let us know,

Ana

@Ana Retamal 
I've cleaned my git repo locally and tried to push it. It told me I needed to pull first since there were changes on the remote that I didn't had but since I committed last, that could not be. So I forced a push resulting in having different size in repos. It's not clear to me how to solve this. Could you help me? I'm talking about the colibry-services repo. 

@Ana Retamalhi, could you please be so kind and help us, we are facing same problem as others gc needed, thanks

Ana Retamal Atlassian Team Dec 11, 2019

Hi @Dmitri Bogatenkov ,

I've checked your repos and found one that is 2GB in size, but after running the git gc the size didn't change. Can you run the following command on your side and show us the output?:

git count-objects -Hv

Let us know and we'll be happy to continue helping you. 

Cheers,

Ana

Hello @Ana Retamal , I have the same problem,  could you please take a look at our repository?
https://bitbucket.org/skipthedishes/react_restaurant

Can we run gc by ourselves in our repos?

Ana Retamal Atlassian Team Oct 04, 2019

Hi @ariel

End users don't have access to the remote repositories as they're hosted in Bitbucket, so you won't be able to run git gc there. Git gc runs automatically on the repos, although sometimes you can ask us to run them manually if you urgently need the size to be reduced to the same size you have on your local (after you've followed the steps at Reduce repository size).

Hope that explains!

Ana

Ther is any news about this topic?

I really need to do gc in many repos.

Please run gc in https://bitbucket.org/grexor/grupo-familia-wilde-l41-encajonadora

 

THANKS

 

Ariel

Hello @Ana Retamal ,

Sorry to bother you with that, but could you run the gc on https://bitbucket.org/keemotion/keelab/?

Thanks a lot!

Hi, please run a remote git gc on https://bitbucket.org/Craftnote/mycrafty

count-objects shows 1.26 GiB, but Bitbucket Cloud shows 2.45 GiB

 

Thanks

@thornberger I ran into this issue last week and was able to get a faster response by submitting a ticket via https://support.atlassian.com/contact/#/.

Just mark the ticket as Level 3.

Hope you get a response soon.

-D

Thanks, problem fixed itself by making a commit which I guess triggered the remote gc.

Ana Retamal Atlassian Team Oct 04, 2019

Glad it got solved, @Tobias Hornberger

The garbage collection usually gets run automatically although sometimes it might take longer. If you need anything else in the future, lets us know.

Best regards,

Ana

1 vote
Ana Retamal Atlassian Team Feb 01, 2018

Hi Francisco, I've checked your repositories but I could not find any repo that big. Were you referring to a different account? If so, can you let me know the name of the account and the repo?

Cheers,

Ana

Hi @Ana Retamal, thanks for the quick reply. This is a private repo, so don't know if you may be able to see it: https://bitbucket.org/warrantygroup/sfdc-service-cloud/

Thank you.

Hello @Ana Retamal l am having the same problem. My local folder is 450MB including .git folder but its 2GB on bitbucket therefore l can not push anymore.

Repo ami-mobile

@Ana Retamal 
Hey!
Can you please help me by reducing the size of the repo on remote?

count-objects shows size-pack: 1868914

In remote repository, it shows 4.11 GB

Repo: https://bitbucket.org/zasemicon/tool

Thanks,

Sheeba Y

Hi,

  Could you please run gc on this repo?.

bitbucket.org/grexor/grupo-familia-wilde-l41-encajonadora

 

thanks very much

@Ana Retamal, hello!

Can you run `git gc` for the repo.

Thank you in advance!

Did you fix this thing?. My repo is over 1GB but the server didnt execut gc.

Could  you please execute gc in bitbucket.org/grexor/grupo-familia-wilde-l41-encajonadora

Hi @Ana Retamal

We have the same issue, could you please help us by running gc on https://bitbucket.org/dealer-crm/dealercrm-dev

Resolved by support.
Thank you! 

Hello Ana, could you do the same for me.
Repo is https://bitbucket.org/robotjox/ny_sctmariae/ 

Hi @Ana Retamal

We have the same issue, could you please help us by running gc on https://bitbucket.org/yamp/dt? 

Thank you 

Ana Retamal Atlassian Team Nov 11, 2020

Hi @yamp, thanks for reacching out!

I've run git gc and the size of your repository has decreased to 109.7 MB.

Hope that helps :) 

Ana 

Solved! 

Thank you very much for the quick reply :) 

Hi @Ana Retamal , I have same issue here https://bitbucket.org/Liikennevirta/ios it is approaching 2GB limit, local copy size is under 500MB, could you please try gc on it ?

Ana Retamal Atlassian Team Nov 05, 2020

Hi  @Ngo Quoc Thang, thanks for reaching out :) 

I haven't been able to find a repo by that name in your account, neither a repo reaching a size of 2 GB. Is that the correct name of the repository?

Let us know!

Ana 

Like Ngo Quoc Thang likes this

Hi, the correct link is https://bitbucket.org/virtaglobal/ios

Sorry I messed it up.

Hi @Ana Retamal

Could you run a git gc on our team's repo :

https://bitbucket.org/accelfs/b737_exec/src/DEV/

https://bitbucket.org/accelfs/qtg/src/DEV/

The repository size is showing around 1.5 Gb on the cloud but I just pulled it on my machine and it's actually much smaller than this. 

Could this be done asap? 

Thanks a lot,

Hi @Ana Retamal

Could you run a git gc on our team's repo : https://bitbucket.org/bzkka/resumes-analytics/src/master/

The repository size is showing 2.02 Gb on the cloud but I just pulled it on my machine and it's actually much smaller than this (304Mb). 

Could this be done asap as the repo is now locked for pushes? 

Thanks a lot,

Vincent

Ana Retamal Atlassian Team Aug 11, 2020

Hi Vincent, welcome to the Community :) 

I've checked your repo and I could see that the size now is 435.0 MB. Whether it was the automated gc or one of my colleagues, looks like the issue is solved, so you should be able to push. 

If you still need any assistance, let us know and we'll be happy to help.

Best regards!

Ana

Creating a support ticket gets it done much faster. After I created the support ticket it was done within a few hrs.

@Deep Can you tell me where to create a support ticket? 

Here you go: https://support.atlassian.com/contact/#/

 

You will need to be logged in to raise a ticket.

I'm done. I really appreciate your help. Thanks @Deep

No problem. Glad I was of some help.

Hello @Ana Retamal ,

Could you please run the remote git gc on two of my repositories:

https://bitbucket.org/makkajai/multiplication-game/src/master/ and https://bitbucket.org/makkajai/montivities/src/master/

Both of these are showing up as under 400MB locally but on bitbucket they are showing up as 1GB+

Thanks in advance

Deep Shah

Hi @Ana Retamal,

I clean my private repo and need to reduce the size with a `gc` please. Thanks to you and your team!

https://bitbucket.org/aerialeng/rca-app/

@Ana Retamal Hi Ana, same problem with one of my repos here, local size is far below 1GB, reported size on bitbucket 1.56GB. Could you please also run a `git gc` there?

Repo is https://bitbucket.org/aliasguru/blender-settings/src/master/

EDIT

Forget my previous comment, I found a way to fix it.

Hi @Ana Retamal,

could you please try and decrease the size of the following repo?

https://bitbucket.org/apac_eco_system/iosregression

Thanks!

hello @Ana Retamal could you also run git gc for mobilembv/iadc_new_website

Hi @Ana Retamal . I have a similar problem. BitBucket says the repo's size is 1.6 Gb but if I clone it the size is not more than 350 Mb. Could you please perform and git gc on my repository ? https://bitbucket.org/traffgen/rhprohost/src/master/

Also is there any way to perform it remotely? As far as I know this is not possible. Thx.

Hi, I have same issue here https://bitbucket.org/Liikennevirta/ios it is approaching 2GB limit, local copy size is under 1GB, could you please try gc on it ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,112 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you