It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

What is the Root URL for SourceTree App?

Jeff Saengsri Apr 30, 2018

I am new to BitBucket, and the company I am freelancing for uses BitBucket to edit their code. So, they already had an existing repository, and I want to create connect it to the SourceTree computer app. Upon install, the app asks for the root url, which I am not to sure what is it. 

I think I found somewhere online that it could be http[s]://<repo_owner>@bitbucket.org/<repo_owner>/<repo_name>.git but that is not working either.

Thank you for those to help em out!

14 answers

1 accepted

9 votes
Answer accepted
Ana Retamal Ortiz Atlassian Team Sep 10, 2018 • edited

Hi everyone!

The main issue in this thread seems to be Bitbucket Cloud users trying to register using the Bitbucket Server method. Please note that there are 2 ways of registering Sourcetree: 'Bitbucket Server' and 'Atlassian account'. If you have a Bitbucket Server account, use the 'Bitbucket Server account'. If you DON'T HAVE a Bitbucket Server account and instead you use Bitbucket Cloud, Github or any other service, you need to register using an Atlassian account.

After this step has been completed and the installation process finished, you'll be able to connect your repos following the steps at Connect your Bitbucket or Github account.

 

Hope that helps!

Ana

Gregg OD Oct 10, 2018

Im installing sourcetree in October and I had the same confusion.

I think its down to human error where you see Bitbucket and you immediately click it without thinking.

Which calls for two changes in the setup:

You should make it more clear.
You should put this information on the setup page so people dont get frustrated and have to Google it.

Thanks,
G

Like # people like this
Cheng Oct 19, 2018 • edited

This UI design makes a simple login process so frustrating

Like # people like this
David Sadowski Nov 05, 2018 • edited Nov 06, 2018

No only frustrating but also annoying. I've just downloaded the latest ST version 3_0_200 onto my Mac OSX 10.13.3 (cannot upgrade to 10.13.6 or 10.14 for other reasons) and am unable to register it using the Server (managed to connect to Cloud but don't want any info to be shared with Cloud account and only our self-hosted BB Server so Cancelled). When tried to access Cloud the app would crash every time after clicking BitBucket Cloud icon 3 times anyway. The BitBucket Server, on the other hand, doesn't reckognise my valid credentials that work on our JIRA server instance - simply rejects any combination. Base URL (take from BB settings), username and password are 100% correct (removed partial login details for security).

Screen Shot 2018-11-06 at 20.04.12.png

Atlassian - what's going on on your side? Everything seem to be progresively degrading on your side...

Like # people like this
gustavo Nov 05, 2018

I just switched to git tortoise :) Solved my problem.

Like Christian Bau likes this
David Sadowski Nov 05, 2018 • edited Nov 06, 2018

Thanks - would do the same but am on a Mac.

Am in the process of exploring other apps atm.

Like Christian Bau likes this
Gregg OD Nov 06, 2018

Shame David - I heard gitKraken is good. It's cross platform and has a pretty cool website! Definitely worth investigating. Let the forum know if it works for you.

Like David Sadowski likes this
Christian Bau I'm New Here Feb 04, 2019

Trying to set up SourceTree is absolutely positively infuriating, and for no good reason whatsoever. As far as I can see this is all about Atlassian marketing trying to collect some information (which is bad enough), but making the process so counter-intuitive and frustrating. 

I use BitBucket server. Accessed without a password, but using an SSH key. To get to BitBucket, I just type in git.something.something.something into the browser, and I'm there. Registering Atlassian? No chance. 

The first absolute idiocy is that the base url must start with https:// or http:// otherwise error "invalid base url". WTF not "Invalid Base URL: Add https or http scheme"? 

Christian Bau I'm New Here Feb 04, 2019

Asked a colleague who knew what to do: The solution is simple. I don't care about Atlassian, I just want this app running. So whatever you _actually_ want to do, just create a throw-away Atlassian account (nowadays called "BitBucket Cloud", just to confuse everyone), register, and never touch that account again. 

David Sadowski Feb 04, 2019

I share your frustration but there is no hope am afraid... I have been using their products for the past 4-5 years, did some certification too but looking back, they simply don't give a s**t about their own customers or community hence am reluctant to further recommend any of their products to my new clients. We've been living for a couple of years with unresolved critical issues in JIRA (while they prioritise other UI tickets purely for marketing purposes) but are constantly evaluating other solutions and if anything promising shows up we'll move away from Atlassian as fast as we can.

Like Oscar Ruano likes this
5 votes
Ana Retamal Ortiz Atlassian Team May 01, 2018

Hi Jeff! Do they use Bitbucket Cloud or Server? If it's cloud, the root URL should be something like https://bitbucket.org/<username>/. You can also refer to Connect your Bitbucket account for additional information. 

Let us know if you have any questions or need any extra help!

Ana

Jeff Saengsri May 02, 2018

Thanks Ana. I actually figured out the answer later that day. For me, it was http[s]://<username>@bitbucket.org/<repo_owner>/<repo_name>

Referring the Connect your Bitbucket account was where I first started, but I believe that was when you already did the setup. SourceTree now has connect to your Bitbucket Cloud / Server when you startup the app for the first time.

I am new to bitbucket and I downloaded sourcetree but when I start installation it asked me to give it ROOT URL and I gave it URL in following formates but it said "Invalid URI: The hostname couldn't parsed."

1. https://<username>@bitbucket.org/<repo_owner>/<repo_name>

2. https://<username>@bitbucket.org/<repo_name>

Can anyone help me please

sheikhsohaib07 May 11, 2018

I am trying the same but no luck so far. Have tried all the give urls formats 

Can anyone share sample url?

 

Scenario to reproduce: Goto C:\Users\username\AppData\Local\Atlassian\SourceTree and remove accounts.json file and re open source tree.

3 votes
luotao wang May 23, 2018

I faced the same problem during installation. The URI is invalid. None of the answers can help me. I tried https://bitbucket.org/username/repo, https://username@bitbucket.org/username/repo, etc. Could you provide an exanmple?

Ana Retamal Ortiz Atlassian Team May 24, 2018

Hi Luotao, seems like you're in the same situation than the users above, they were trying to register using their Cloud credentials, but the only options available for registration are Bitbucket Server credentials and Atlassian account. If that's your case, you'll need to register the product using your Atlassian account (email address and password) and after that you'll be able to connect your Bitbucket Cloud account. 

If you're not sure, you can post a screenshot and we'll guide you.

 Kind regards :)

Ana

Grant Aylward May 28, 2018

Please do that Ana! Thanks

Ana Retamal Ortiz Atlassian Team May 29, 2018

Hi Grant! I'm not sure what are you asking me to do... What issue are you experiencing?

If it's different from the question the author posted, please submit it as a different thread so we can keep this tidy and helpful for the rest of the users :)

Kind regards!

Ana

Nick Skriloff Jun 04, 2018

Ana, 

I am trying the following steps

1. Install Source Tree for Windows

2. I go to https://bitbucket.org/darden/registrar/src/master/ and click clone and choose https.  It gave. https://nickarino@bitbucket.org/darden/registrar.git

3.  I took that url and put it in.  When I type in my username I use login to bitbucket I get the below error, "Invalid URI: the hostname could not be parsded"

Why? 

2018-06-04 15_55_52-Sourcetree _ Free Git GUI for Mac and Windows.png

Jim Redmond Atlassian Team Jun 04, 2018

Don't use the "Bitbucket Server" type - bitbucket.org is Bitbucket Cloud, which uses Atlassian Account.

Nick Skriloff Jun 04, 2018

Thanks James.  Can you tell me exactly what to type?  I do not understand

Jim Redmond Atlassian Team Jun 04, 2018

The Bitbucket Server screen is incorrect if you're using Bitbucket Cloud, so you'll need to click "Back" and choose the Atlassian account type instead.

Nick Skriloff Jun 04, 2018

Great.  I have logged in.  Now what are the steps to get past this?  I currently authenticate by ssh with a key. 

2018-06-04 21_03_26-What is the Root URL for SourceTree App_.png

 

If I do this on my local repo that works, I get

C:\dev\registrar>git remote -v
origin ssh://git@bitbucket.org/darden/registrar.git (fetch)
origin ssh://git@bitbucket.org/darden/registrar.git (push)

Jim Redmond Atlassian Team Jun 04, 2018

First, change "Bitbucket Server" to "Atlassian account". If your repos are at bitbucket.org then you are not using Bitbucket Server (bitbucket.org is Bitbucket Cloud).

Bitbucket Server is self-hosted and has a URL other than bitbucket.org.

Once you've changed from "Bitbucket Server" to "Atlassian account" then you should be able to continue.

Nick Skriloff Jun 05, 2018

I was able to continue, but now I need to set up my remotes.  What are my next steps.  When I choose "Bitbucket" I cannot put anything in the host URL. 

2018-06-05 08_53_14-Sourcetree.png

Ana Retamal Ortiz Atlassian Team Jun 06, 2018

Hi @Nick Skriloff, the Atlassian account was only needed to register the product upon installation, you won't need it in Sourcetree anymore.

Now, you're trying to set up your remotes, which are hosted in Bitbucket Cloud. Once you select 'Bitbucket' in the drop-down, you'll need to enter your Bitbucket username in the 'Username' field (all the Bitbucket Cloud URLs are https://bitbucket.org/<username>/, that's why we only need the username as that's what makes your account unique). In your case, you'll need to enter 'darden' (without the quotation marks). 

This is explained at Connect your Bitbucket account.

Hope that helps! Let us know if you have any other difficulties and we'll be glad to help.

Cheers!

Ana

Nick Skriloff Jun 06, 2018

Ana, 

Thank you.  Should I talk to my admin to fix this? 

2018-06-06 05_12_11-Window.png

Rajib Samanta Jun 12, 2018

I am unable to connect to BitBucket Server.

I got the following URL from clone:

https://rs04750@cedt-icg-bitbucket.nam.nsroot.net/bitbucket/scm/c150329/cms.git

I put the same on SourceTree to connect to BitBucket Server, but I am getting the error "Failer to list groupings for user"

Please let me know how to resolve this issue?

Error Message.png

Rajib Samanta Jun 13, 2018

Any update on my query?

1 vote
Waqas Nisar Jul 23, 2018

@Ana Retamal Ortiz Thanks.

Following comment helped me and I've successfully set it all up.

>Hi @@sheikhsohaib0 and @Mohammad Tasneem Faizyab, looks like you both have >Bitbucket Cloud accounts, but you're trying to use the Bitbucket Server authentication >prompt to log in. If you don't have a Bitbucket Server account, you'll need to register >using the other option (Atlassian account) and once the installation process is >completed, you can add your Bitbucket Cloud account following the steps at Connect your Bitbucket account.

>Let us know if you still have any issues and we'll be glad to continue helping you!

>Kind regards,

>Ana

0 votes
Jeff Saengsri May 11, 2018

Try this. If you guys have an existing repo that you have access to, go to your BitBucket account. Once you get to that repo that you want access to, click the button clone thats near the top right. It will give you the a git command line, copy everything besides the git clone part, which should end up like what I said early,   http[s]://<username>@bitbucket.org/<repo_owner>/<repo_name>. Whatever your repo clone gives that should be it though.

sheikhsohaib07 May 11, 2018 • edited

2018-05-11_19-04-07.jpg

This is how I'm doing it as I own this repo so I have used my username and my repo name

Jeff Saengsri May 11, 2018

Are you the owner of the repo or someone else the owner? If someone else is, it would be their username after @Bitbucket.org/

sheikhsohaib07 May 11, 2018

I'm owner so its my username after @Bitbucket.org/

Jeff Saengsri May 11, 2018

Then, I'm not quite sure how to fix your issue :( I used the format before and it worked. I'm still new to BitBucket

sheikhsohaib07 May 11, 2018

Can you try the scenario I mentioned to reproduce the issue?

Jeff Saengsri May 11, 2018

I did and it works, but its a little different for me since I'm already inside the web app.

sheikhsohaib07 May 11, 2018

This annoying issue has wasted my day.

sheikhsohaib07 May 11, 2018

so is there any other way to get rid of this 

It just keeps asking me to login again and again

 

111.jpg

Jeff Saengsri May 11, 2018

I'm not sure where that is popping up, and I don't know how else to help you. I hope your day gets better  

Ana Retamal Ortiz Atlassian Team May 14, 2018

Hi @sheikhsohaib07 and @Mohammad Tasneem Faizyab, looks like you both have Bitbucket Cloud accounts, but you're trying to use the Bitbucket Server authentication prompt to log in. If you don't have a Bitbucket Server account, you'll need to register using the other option (Atlassian account) and once the installation process is completed, you can add your Bitbucket Cloud account following the steps at Connect your Bitbucket account.

Let us know if you still have any issues and we'll be glad to continue helping you!

Kind regards,

Ana

Nia Christian May 25, 2018

I'm having the same issue. I registered using Atlassian but it still asks me for the URL above. I've tried all combinations and have no idea what I should be entering in this space. To make matters worse my Atlassian account is connected with my gmail. Does it want my gmail password or my Atlassian password? I haven't used Atlassian to log in for years.

0 votes
Jan Stark Aug 07, 2018

Guys, I think I got the solution for lots of people.

For our team it worked if you just put in your browser url of the repository .

 

It should look something like this:

https://bitbucket.org/repositoryowner/repositoryname/src/master/

 

Cheers!

0 votes
Divyamsh Sep 08, 2018 • edited

git.PNGHey,I'm facing this sort of issue

can anybody guide me through this?

gittt.PNGI've tried another root url and this error appears

gitt.PNGthis message appears when i try to login with atlassian

0 votes
Ana Retamal Ortiz Atlassian Team Sep 10, 2018

Hi @Divyamsh, in Sourcetree there are 2 ways of registering: one is using your Atlassian account, and the other one is using your Bitbucket Server account. You are a Bitbucket Cloud user, however you're trying to register using the Bitbucket Server method. Please go back and select 'Atlassian account', then you'll be able to log in using your Bitbucket Cloud credentials (your Atlassian account and Bitbucket Cloud account share the same email address and password).

Let us know if you need any further assistance!

Ana 

Divyamsh Sep 10, 2018

Hey Ana,

Please go through the 3rd screenshot

When i select atlassian account that kind of error message pops up.

Ana Retamal Ortiz Atlassian Team Sep 11, 2018

Hi @Divyamsh

That's a Javascript error usually caused by an old version of the browser. Sourcetree relies on Internet Explorer for authentication, can you make sure it's updated to the latest version?

Apart from that, IE needs to be configured at a minimum as follows:

- Cog/Internet options/Security settings need to be enabled

- Misc/Access data sources across domains

- Misc/Allow META-REFRESH

- Scripting/Active Scripting

- The browser mode set to 10

- The document mode set to 10

These can be set using the F12 developer tools.

Those are the settings that matter. It should also be able to set them indirectly by:

- making sure https://id.atlassian.com is NOT set to be rendered in Compatibility Mode

- Set Cog/Internet options/Security to Medium-High

Let us know if this helped you!

Best regards,

Ana

0 votes
Michael W Joyner Sep 26, 2018

This is crazy. I can't login I am pulling my hair out trying to login.

0 votes
gustavo Oct 05, 2018

I am facing the same problem. This is incredibly annoying. Who came up with this horrible idea!!!!! You are really making sure we don't use the source-tree anymore.

anyway, I tried what other people suggested and no luck.

I have a repo called "arara" and my user name is gmmo, see the screen shots and the problem. What would be the correct strings?

 

repo.png

trying to start source tree, and stuck:

 

stuck_in_licence.png

thank you

0 votes
Ankur Shrivastava Oct 12, 2018

I struggled with the same issue for a long time.

I wanted to connect SourceTree with my BitBucket Server.

Reading the several hints on this page, I tried the URL that I got when I hit clone on my repo on the server.

That didn't work either.

So, I selected the option of Clone using SourceTree and voila !!!

It opened up the appropriate window and when I hit clone, my repo and branches etc. are there now in SourceTree.

David Sadowski Nov 06, 2018

Hi,

Just to let others know - this didn't work for me whenever am trying to Download using SourceTree v3_0_200 using both HTTPS or SSH. :(

 

Getting really fed up with Atlassian products now... time wasting stuff quite frankly.

0 votes
Charles I'm New Here Nov 28, 2018

I can add my Bitbucket account in Tower , But SourceTree failed, I am confused

0 votes
Deleted user Jan 10, 2019

The UI contant is quite confusing, what's the meaning of the "Root URL" ? You guys don't even explained it well ! 

0 votes
Novalia Popy I'm New Here Mar 16, 2019

applikasi cacat

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

1,635 views 2 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you