What do I need to do to connect my Bitbucket and Trello accounts?

I have a public repo in BitBucket with boards enabled.  When I click the "Connect" button on the Trello settings for the repository, nothing happens.

What do I need to do and what settings do I need in order to get Google Chrome on Mac to do something when I click the connect button?

3 answers

1 vote
KenFai I'm New Here Jan 15, 2018

I found a solution. If you are using Chrome, go to Settings > Advanced > Content Settings > Cookies > Block third-party cookies > make sure it's Disabled.

chrome-thrid-party-cookies.png

Did you find a solution to this? I have the same problem.

I am also experiencing this problem. Any solutions yet?

0 vote
Ian Dick Atlassian Team Sep 18, 2017

Hi Eric. I work for Atlassian and I helped out on the Trello + Bitbucket integration. Which page are you on when you click "Connect"? Are you in the "Trello" settings in your public Bitbucket repo? If you haven't previously connected Bitbucket Cloud to Trello, clicking "Connect" should pop a dialog for authorizing the integration with your Trello account. You don't see a dialog when you click "Connect"? If you know how to access the developer tools in Google Chrome, do you see any console errors when you click "Connect"?

To get help with your specific account you can always raise a support ticket with us at https://support.atlassian.com/contact. A support engineer should be able to help you get unstuck.

Hi Ian, does the Bitbucket repo need to be public? When I click on Connect, no popup comes up. On page load, there is an error in the console (GET https://api.bitbucket.org/internal/trello/me 403 ()). No new errors after clicking on Connect.

Ian Dick Atlassian Team Sep 19, 2017

The repo doesn't need to be public. I'd advise you to raise a support ticket so you can have a support engineer help you out with this.

Any solution to this? Same problem here.

api.bitbucket.org/internal/trello/me Failed to load resource: the server responded with a status of 403 ()

Ian Dick Atlassian Team Jan 02, 2018

@Tineke TimmermanI don't think we're currently tracking any browser-specific problems with the integration. If you raise a support ticket at https://support.atlassian.com/contact a support engineer should be able to help figure out what's going on.

KenFai I'm New Here Jan 15, 2018

I found a solution. If you are using Chrome, go to Settings > Advanced > Content Settings > Cookies > Block third-party cookies > make sure it's Disabled.

chrome-thrid-party-cookies.png

Having the same issue, is there any update or solution?

@KenFai  "Block third-party cookies" is disabled in my browser. But still getting 403 error.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Asked 3 hours ago in Confluence

What are the resources that you use to learn more about Atlassian Products?

I am gathering information about resources available for Atlassian product knowledge transferring for a presentation in our local Atlassian User Group. I want to group them in four categories From ...

34 views 3 3
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you