Webhook is running, but provides 'Invalid URL' when saving in Bitbucket Edited

Hey all!

I have finished setting up the webhook on our server which is hosting the development build of our project. I can navigate to the page which lets us know that it is up and running:


2017-06-16 13_51_38-Mozilla Firefox.png

When linking to this in the 'Bitbucket -> Repository -> Settings -> Webhooks' section, we get an "Invalid Url" error when saving.

So far as I can tell, everything is configured correctly as per this tutorial, so I was wondering if anyone would be able to provide a hand!

Thank you =)

1 answer

This has been resolved!

I had been using underscores in the URL which I created, and django has trouble interpreting those underscores. Concatonating the URL by removing underscores fixed the problem, and the webhook now works.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

706 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot