It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Webhook is running, but provides 'Invalid URL' when saving in Bitbucket Edited

Hey all!

I have finished setting up the webhook on our server which is hosting the development build of our project. I can navigate to the page which lets us know that it is up and running:


2017-06-16 13_51_38-Mozilla Firefox.png

When linking to this in the 'Bitbucket -> Repository -> Settings -> Webhooks' section, we get an "Invalid Url" error when saving.

So far as I can tell, everything is configured correctly as per this tutorial, so I was wondering if anyone would be able to provide a hand!

Thank you =)

1 answer

This has been resolved!

I had been using underscores in the URL which I created, and django has trouble interpreting those underscores. Concatonating the URL by removing underscores fixed the problem, and the webhook now works.

HI @alex-gelinas

Can you please add the example of URL how you have been added.

We are facing the same issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Bitbucket

Contest: Share your custom Bitbucket Pipe and win

Announced in this blog, this holiday season we’re celebrating all things CI/CD and between now and the end of 2019 we’ll be showcasing content, use cases, feature announcements and more. One featur...

1,121 views 4 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you