Since `RUN --mount=type=ssh` is disabled, how can I configure SSH with the running ssh-agent in my CI container? We are using the common docker-in-docker setup of running our own CI container and having docker compose build the image for us. It is failing due to your unfortunate limitations:
```
service:
build:
context: .
ssh:
- default
```
and the Dockerfile requires a
```
RUN --mount=type=ssh pip install [...]
```
Produces:
```
docker compose run app ./util/lint
+ docker compose run app ./util/lint
Network build_default Creating
Network build_default Created
app Pulling
app Warning
#1 [internal] booting buildkit
#1 pulling image moby/buildkit:buildx-stable-1
#1 pulling image moby/buildkit:buildx-stable-1 2.7s done
#1 creating container buildx_buildkit_default done
#1 ERROR: Error response from daemon: authorization denied by plugin pipelines: --privileged=true is not allowed
------
> [internal] booting buildkit:
------
Error response from daemon: authorization denied by plugin pipelines: --privileged=true is not allowed
```
Which is a bit silly. How are we supposed to work around these limitations?
Also how far out is the plan to ditch Kubernetes so we can have features your competitors offer like not having to work around trivial things and mutli-arch builds? That would be great!
No Markdown formatting for a product who's only made for developers? Another oops.