It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Use SSH in a custom pipe

I want to download from private bitbucket repository in a custom pipe. This works in a pipeline - I added public key into access keys. However in pipe it fails with 'Host key verification failed.'

I found this post:

So I tried adding the key with

ssh-add /opt/atlassian/pipelines/agent/data/id_rsa

This failed so I also tried asdding id_rsa_tmp as suggested in the post, but that doesn't work either. How can this be achieved?

2 answers

0 votes

Have you configured the 
Known hosts in the Pipelines > SSH Keys section in a repo settings?

Also, another option would be to disable the host key verification when making an ssh connection in your pipe:

$ ssh -o StrictHostKeyChecking=no

 I hope this should solve the issue.

Any updates on this issue @segy? I'm have the same problem here

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Bitbucket Server 7.0 is here!

Hello Community, I’m Anton Genkin, a product manager on the Bitbucket Server and Data Center team and am excited to share that Bitbucket Server 7.0 is now available! It's a platform release, one th...

1,109 views 6 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you