Upload from pipeline to downloads directory - where is the file?

Hi,

I followed the instructions on

https://confluence.atlassian.com/bitbucket/deploy-build-artifacts-to-bitbucket-downloads-872124574.html

and everything worked fine.

Even the curl command finished without an error, uploading a 16M zip file.

But when I click on "Downloads" I do not see the file.

What am I missing?

1 answer

1 accepted

0 votes
Accepted answer

It's working now. I've set the environment variable at the wrong location.

How did you make it work? I have the very same issue, All seems to work but files is missing on download. 

 

In particular, what did you write for the --form files?

 

Thanks.

Solved, my authentication variable was wrong!

Hello, I have the same issue :)

and o'm pretty sure of my authentication keys!

Hi Asim,

Did you make sure that:

 

1) the App Password is in your account settings, not in the repo itself.

2) the variable used in your pipilne for authentication is ${BB_AUTH_STRING}

3) the variable BB_AUTH_STRING is defined in environment variable of your account

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

655 views 5 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you