Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Upgraded from git 2.33 to 2.36 and now can't access repos


I upgraded from git 2.33 to today, and suddenly I'm unable to clone or pull from BitBucket. I get the following error:

git@"domain": Permission denied (publickey).

fatal: Could not read from remote repository.

Please make sure you have the correct access rights

and the repository exists


I have found several solutions online (including these forums) and no luck so far. I've recreated SSH keys, made sure they are in my ssh-add/uploaded to BitBucket, etc. Still, no luck. It worked fine immediately before I did the git upgrade.

Has anyone experienced this with the upgrade to 2.36 or have other suggestions on how to get this to work?

2 answers

1 vote
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Jul 13, 2023

The problem is with ssh keys. 

Git 2.33 and above, rsa keys are disabled by default.

You need to use ed25519. You need to generate ssh key usinng 

ssh-keygen -t ed25519

It will solve the problem

I have experienced this after upgrading to Git 2.36.0 and using Bitbucket 7.17.1.  I was not able to resolve the issue but, upgrading Bitbucket to 7.21.2 fixed it.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events