Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Unknown state in response


We're trying to setup SSO on our Bitbucket DC instance with OIDC and we're seeing this error after logging in on our IDp(Keycloak).

com.atlassian.plugins.authentication.impl.web.usercontext.AuthenticationFailedException: Unknown state in response

Does anymore have more info on the error?

The stack trace is

com.atlassian.plugins.authentication.impl.web.usercontext.AuthenticationFailedException: Unknown state in response
	at com.atlassian.plugins.authentication.impl.web.oidc.OidcConsumerServlet.lambda$doGet$0(
	at java.base/java.util.Optional.orElseThrow(
	at com.atlassian.plugins.authentication.impl.web.oidc.OidcConsumerServlet.doGet(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at com.atlassian.plugin.servlet.DelegatingPluginServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at com.atlassian.plugin.servlet.ServletModuleContainerServlet.service(
	at javax.servlet.http.HttpServlet.service(


4 answers

I am getting this error after a user as already been into the application. Now they cannot get in and the logs are saying Unknown State in Response.


Any help?


i've got same problem with confluence and Cas Apero OIDC. I'm not sure what to write in "username claim"

i try with {sub} or {id} or something else, and i"ve always the same error

a solution for someone ?

@esk I'm facing this issue, were you able to solve it? 

0 votes
Gonchik Tsymzhitov
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jan 21, 2021


Have you tried to clean config and do it from scratch? 

Hi. Which config to clean?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events