Missed Team ’24? Catch up on announcements here.

×
Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Unable to start pipeline: UI hangs

fellerts February 14, 2023

Hi,

Today I noticed that the pipeline in one of our repos was not triggered by a commit like I expect. I then tried to manually start a pipeline on the relevant branch, but the pipeline UI just hangs forever showing spinners. Navigating back to the pipeline view, I don't see the new pipeline at all. I also tried triggering a pipeline for master with the same result.

This has been working fine for weeks up until yesterday. I did not change any settings or update bitbucket-pipelines.yml. I have tried

  • disabling and enabling pipelines on the repository
  • deleting and recreating the two Linux shell runners

but nothing has helped. As far as I know, this is the only affected repository/pipeline in our organization.

Has anyone experienced the same thing? What can I do to resolve this?

 

Edit: I should mention that a colleague of mine also tried to manually start pipelines in this repository and failed, so we can probably rule out any device- or user-specific problems. I'm also uploading a screenshot of what I'm seeing in case it wasn't clear.

 

thanks,

Fredrik

2 answers

1 accepted

0 votes
Answer accepted
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 15, 2023

Hi Fredrik,

I see that you created a support ticket for this issue, so I would suggest waiting for feedback on the ticket. Please provide the URL of an affected Pipelines build in the ticket, so that the engineer working on your case can check the build logs and investigate what happened.

Kind regards,
Theodora

0 votes
fellerts February 14, 2023

Hm, the screenshot I uploaded didn't stick for some reason. Trying again here:

bb-pipelines-hang.png

Graham Benton February 20, 2023

Was there any solution to this?  I am experiencing the same problem.

fellerts February 21, 2023

@Graham BentonAtlassian is still investigating in our internal ticket, I'll make sure to post here if/when resolved.

I'm using Linux Shell runners, and the problem might stem from having several labels for the runners in the yml file, but I'm not sure. We were able to get it going again by shuffling the labels around but it didn't last unfortunately.

Graham Benton February 21, 2023

Thanks for replying.

I don't have anything complex, just a pipeline to build a Docker image and push it to a repository. 

It is in a branch section of the pipeline, which is the only thing that is vaguely non standard.

Graham Benton February 23, 2023

My support ticket is still frozen but the pipeline seems to be working for now.  

fellerts February 27, 2023

@Graham BentonThe BitBucket engineering team pushed a back-end fix which resolved the issues in my pipeline. Seems like something went wrong with my use of labels and/or Repository Access Tokens.

Glad to hear yours is working as well.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events