Unable to start new instance of stash on amazon ec2

I'm having problems running a clean install of Stash on Amazon EC2 linux. I have verified that the stash home, and java home variables have been set correctly. Java is using oracle 7 update 51 as well.

I have turned on debug logging and you can find my log files at the links below.

catalina.out

https://gist.github.com/todd2982/9291741

atlassian-stash.log

https://gist.github.com/todd2982/9291725

2 answers

1 accepted

EC2 Micro does not have the resources to host the tomcat server needed for stash. Moved to larger instance without issue.

Hi Todd,

Thanks for the logs. What happens when you try to connect to Stash? Do you get an unavailable screen, something about plugins not started?

It's hard to tell what went wrong from the logs, normally it's fairly easy because there will be errors. My guess is that Stash is taking too long to start and all the plugins are timing out:

2014-03-01 15:44:25,541 WARN [active-objects-ddl-0] c.a.a.o.AOConfigurationServiceProviderImpl Timeout (30000 MILLISECONDS) waiting for ActiveObjectConfiguration for Bundle : com.atlassian.stash.build-integration [64].

You might be able to increase that timeout by setting the following System property:

-Datlassian.plugins.enable.wait=300

This discussion may be of interest, it's not about Stash but about problems running JIRA on EC2:

https://answers.atlassian.com/questions/42729/jira-fails-to-start-due-to-bundled-plugin-is-disabled-after-upgrade-from-4-4-to-5-0

Finally, I might suggest raising a support ticket as well

Cheers,

Charles

Charles,

I never can get to the website. I either get connection time outs or connection refused. I assume the refusal is because I'm not giving tomcat enough time to start.

I will try this first thing in the AM. I assume this belongs in the start-stash.sh script?

Try the setenv.sh script instead.

That command does not seem to be vailid for Stash.

bin/setenv.sh: line 37: -Datlassian.plugins.enable.wait=300: command not found

Hi Todd,

Sorry, should have been more explicit, look inside the file:

#
# Occasionally Atlassian Support may recommend that you set some specific JVM arguments.  You can use this variable
# below to do that.
#
JVM_SUPPORT_RECOMMENDED_ARGS=""

So add your system properties to that variable.

Cheers,

Charles

I added it to the required options originally. I did get stash to start by lowering the JVM max memory, but catilina runs out of memory shortly after. I'm running all this on a micro instance of ec2, and I don't think that is providing enough memory.

Stash has the smallest memory requirements of all the Atlassian products, but unfortunately the base Tomcat/Spring/Hibernate/Plugins requirements push that up to a non-trivial size. I couldn't say if it is possible to run on a micro EC2 instance.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,011 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you