Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,990
Community Members
 
Community Events
176
Community Groups

Unable to run 32-bit executable on Ubuntu 20.04 on Pipelines

Hi there, 

I am unable to run a 32-bit executable inside docker on Bitbucket Pipelines. 

I have a custom docker image which I have added all that is required to run a 32-bit GCC cross compiler. This same docker image works as expected when running on Windows (using Docker on WSL). When I run the same docker image and build scripts inside Bitbucket Pipelines then I get an exception.

bash: /opt/mspgcc/bin/msp430-gcc: cannot execute binary file: Exec format error  

 

Here is part of my Dockerfile:

FROM ubuntu:20.04

RUN dpkg --add-architecture i386 && \

    apt-get update && \

    apt-get install -y build-essential libc6-i386 libstdc++6

# Install MSP-GCC 20081229
...

 

Here is my bitbucket-pipelines.yml:

image:

  name: company.azurecr.io/msp430-gcc:20081229

  username: $DOCKER_USERNAME

  password: $DOCKER_PASSWORD

pipelines:

  default:

    - step:

        name: Build Project

        script:

          - cd arr01-02

          - msp430-gcc -MM -mmcu=msp430x247 -O2 -Wall -Wunused -I./include/ src/variant.c src/arr01-02.c src/temperature.c src/bms.c src/flash.c src/scale.c src/stream.c src/can.c src/usci.c

 

This is pretty much identical to Unable to run 32-bit executable on Ubuntu 16.04 on Pipelines . The suggestion was to email Bitbucket support and ask them to enable 32-bit support on the Pipeline. However, every support avenue I have tried has brought me here. 

Is anyone able to assist me with enabling 32-bit support for my Pipeline? 

Kind Regards, 
Jason. 

3 answers

0 votes
Norbert C Atlassian Team Jan 27, 2022

Hi Jason,

I would like to inform you that I've created a support ticket for your issue, reference number is: BBS-179496

I'm going to keep you informed in the support ticket. You can open this support ticket by clicking on the link which you've received.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Hi Norbert, 

Thanks for your help on this. I have clicked on the ticket and will be following along. 

Kind Regards, 
Jason.

Norbert C Atlassian Team Jan 28, 2022

You're welcome Jason, I'm always happy to help :)

0 votes
Norbert C Atlassian Team Jan 26, 2022

Hi @Jason 

I would like to inform you that I informed the engineering team about this issue and will update you shortly with our findings.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

0 votes
Norbert C Atlassian Team Jan 24, 2022

Hi Jason,

Thank you for contacting Atlassian Community, I'm Norbert from Bitbucket Cloud Support and I'm here to help you.

Can you let me know whether if you're having this issue on your personal Workspace or with the pr*******n Workspace? 

I'm looking forward to hear from you.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Hi @Norbert C

Thanks for getting back to me. 

I'm having issues in the pr*******n Workspace. There is a tr*-firmware repo with a pipeline that is currently failing due to the issue explained above. 

I am able to use this exact docker image to run the build scripts on a Windows PC and everything behaves as expected. Others have suggested that maybe the docker containers for Pipelines are being run using a configuration/environment which does not allow for 32-bit executables to be used. 

Kind Regards, 
Jason. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events