Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,900
Community Members
 
Community Events
176
Community Groups

Unable to reduce the size of the repo

I have tried more than 100 times to reduce the size of my repo but am unable. I actually deleted the huge file that was problematic but still the size is not going down! What else can I do?

1 answer

1 vote

Hi @motieno,

A garbage collection may help reduce the repo's size. End users cannot run this for their remote repos, but I can help.

Could you please let me know the following so I can identify the repo and run a git gc for it?
- the last 2 letters of the repo name
- the last 2 letters of the workspace this repo belongs to
- and the size that you see for this repo on Bitbucket website (you can find that in Repository settings)

Kind regards,
Theodora

Last two letters of repo: ce

Last two letters of the workspace: no

Size: 4.83 GB

Hi @motieno,

I ran a git gc for this repo and its size has been reduced to 3 GB.

Does this agree with the size of your local repo if you run git count-objects -Hv ?

You should be able to push to the repo now, but its size is still quite large, so I would suggest reducing it further, if possible.

You can check the following reply I gave to another community question for more details:

As I mentioned in that reply, if you proceed with history rewrite and push to your repo, it will need another garbage collection. You can let me know, and I can then run it.

Kind regards,
Theodora

My only worry is even after trying to reduce the pack size by removing the large file that caused the challenge, the local repo is still huge. I actually separated the project files but still the pack size is still big

I however confirm that the size of the local repo is close to the remote repo. Many thanks

The push is on. At 25% I will request for garbage collection shortly

The size has shot again to past 3.54GB, however my local repo is 2.77 GB 

Hi @motieno,

I ran another git gc for the repo and its size is 2.9 GB now.

  1. What operation did you perform to remove the large file from the repo?
    Did you commit the file's deletion?
    Or did you rewrite history to remove it?

  2. If you open this repo on Bitbucket website and then its Commits page, do you see there the commit with the large file?
    If yes, can you select this commit to open it, and let me know if you see the large file listed there?

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events